+ Start a Discussion
Jansi AJansi A 

Is Eclipse Supports lightning components Development?

Hi,

Our team is trying to use Eclipse IDE for Lightning Development, so added Force.com plugin for Winter 17 Developer SF Instance with help of below URL.
https://developer.salesforce.com/page/Force.com_IDE_Installation

Able to fetch the Lightning componets to Eclipse from SF Instance, but when I am trying to edit existing component or while creating new lightning component, if some error exists due to wrong syntax, it is not showing the ERRORS while saving.  Is this the limitation or is there a way to enable to show these kind of errors?


Regards
Jansi
SandhyaSandhya (Salesforce Developers) 
Hi Jansi,

It seems like it works with eclipse Mars with Java version 8.I have not tested, but please refer below link which has a simialr discussion.

https://developer.salesforce.com/forums/?id=906F0000000MKK9IAO

Hope this helps you!

Please mark it as Best Answer if my reply was helpful. It will make it available for other as the proper solution.
 
Thanks and Regards
Sandhya