+ Start a Discussion
Shannon Andreas 21Shannon Andreas 21 

Issue with Newly Created Record Submit for Approval through Process Builder

Hello!

I have created an approval process on the case object as well as a process builder to automatically submit for approval.

User creates and saves the case (Status = New)
Process Builder should kick off and submit for approval.

The approval process has the following criteria:

RecordType = "Tour"; Status = New

Process builder uses the same criteria. The action is Submit for Approval, Does not override entry criteria.

When I save the case record, the process does not kick off with the above criteria.

Now, if I change the process builder to ignore the entry criteria, the process builder kicks off. However, I get tons of flow errors on cases that it should not have run for! I am assuming it is because there is no criteria being checked for record type. I do have this criteria, but chose to ignore. What is going on??

Thanks,

Shannon
 
NagendraNagendra (Salesforce Developers) 
Hi Shannon,

Please check with below blog on how to automatically submit a record using process builder where a step by step explanation is given.May i suggest you to please check with below process step by step and let us know still if you face issues. Please let us know if this helps.

Regards,
Nagendra.
Brian Regan 3Brian Regan 3
Hi,
​I am getting a similar error but it only happens when a paticular profile attempts to submit for approval.
When I attempt to do so successfully submits to the approval process but when a user without "modify all" on the object tries they are unable to.
Any suggestion why?

Cheers, 
Brian