+ Start a Discussion
Tasnim M. TailorTasnim M. Tailor 

Create an Account Using SOAP API and SoapUI

I am not able to get through this challenge. 
I logged in through SOAPUI and used the session id to create an account. The account gets created and returns success. However when I try to validate the challenge in trailhead, it gives me an error - 

Challenge Not yet complete... here's what's wrong: 
It doesn't appear that you have logged in using SoapUI.

I am not sure what did I miss out.
SandhyaSandhya (Salesforce Developers) 
Hi Tasnim,

Please consider below points.

1.Please check if you have connected to same DE org or Trailhead playground where you have done your work in the trailhead.To do this click on" launch your hands on org" and select the DE org or trailhead playground where you have your work and then check challenge.

 OR


Go to Trailhead Profile -- settings -- make the DE org which you have worked as default then check the challenge.


 Trailhead released with new updates. Please refer below link how to take challenges in trailhead.

https://force.desk.com/customer/portal/articles/2643793-trailhead-profile-signup-login-faq?b_id=13478


Hope this helps you!

If this helps you, please mark it as solved.

Thanks and Regards
Sandhya
Tasnim M. TailorTasnim M. Tailor
I have been working on other challenges and able to validate them successfully. The only problem is with the SOAP API challenge where it is giving me a specific error message even though I logged into SOAPUI, used the sessionid that I received from the Login() request and used it to create Account Records successfully. The records get created but the challenge isn't getting validated.
Knowledge loverKnowledge lover
I got the exact same error as "Challenge Not yet complete... here's what's wrong: 
It doesn't appear that you have logged in using SoapUI."  even though I logged in via SOAPUI with success 



 
amrutha kommuriamrutha kommuri
Hi,

I have a trouble completing this challenge.  Please tell me what's wrong.

User-added image

Thanks.
Kaustubh LabheKaustubh Labhe
Hi,

Were you able to resolve this? Facing with the same issue. I am able to login and create account, yet Trailhead wouldnt recognize it. 

Thanks :)
Tasnim M. TailorTasnim M. Tailor
Hi Kaustubh - Yes I was able to validate this challenge. Just close the SOAPUI and try back. It worked for me. Also delete the accounts previously created by that name.
 
Kaustubh LabheKaustubh Labhe
Hi,
I have tried all. No luck :(
Could you have a look at my screenshots below and let me know if you see something odd. I am using custom domain btw, but have tried with the normal instance url as well. 

Thanks :) 


User-added imageUser-added image
Malen FloresMalen Flores
HI @amrutha seems like you have to deactivate Require TLS 1.1 or higher for HTTPS connections. Go to setup and type critcal update.

I hope it will help you.
Emad Issa 8Emad Issa 8
Here is what you need to do:

If you are using windows goto - edit this file C:\Program Files\SmartBear\SoapUI-{VERSION}\bin\SoapUI-{VERSION}.vmoptions
and add:

-Dsoapui.https.protocols=SSLv3,TLSv1.2

restart SOAPUI and it should work.
Subhash DeshmukhSubhash Deshmukh

Hi guys, 

I also faced the same issue related to 'Require TLS 1.1 or higher for HTTPS connections'. I checked in critical updates but there I don't see this particular option to deactivate.

Adding screenshot of critical updates here.

Critical updates screeshot

I am using Salesforce Developer Edition.

Chetan KapaniaChetan Kapania
I am not able to get through this challenge. 
I logged in through SOAPUI and used the session id to create an account. The account gets created and returns success. However when I try to validate the challenge in trailhead, it gives me an error - 
User-added image

Kindly assist.
Brandon Feather 6Brandon Feather 6
I finally figured out the "It doesn't appear that you have logged in using SoapUI." error, I had to remove the LoginScopeHeader section from the header on the login call .

User-added image
Rohan SarafRohan Saraf

hi..!! Tasnim M. Tailor

Hi tried even that too but it did not work..!!!

Could you suggest anything else
 

Rohan SarafRohan Saraf

hi.....Brandon Feather 6

you solution worked for me thankx you......
 

Roop Kumar Singh BondiliRoop Kumar Singh Bondili
hi @Brandon, your solution worked for me too. Thanks
AnuSFDCDevloperAnuSFDCDevloper
It worked as per Sandhya's suggestion(date Dec 21-2016).
Initially, Trailhead Playground name was there near Launch. When i click Check Challange it didnt work.
Once i change the DE org from my Trailhead Playground and check the challange, IT WORKED.
Thanks Sandhya!!
Satya JaragSatya Jarag
Hi,
For TLS realated issues - 
  • You should have modify SoapUI-5.3.0.vmoptions file in SOAP UI installed folder.
  • which is basically located  in 
    'C:\Program Files\SmartBear\SoapUI-5.3.0\bin' .
  • Edit file and add -Dsoapui.https.protocols=TLSv1.2  , see below -
  • User-added image

Thanks,
Satya Jarag
Chetan KapaniaChetan Kapania
Hi Satya,

Thanks for the response. I tried your resolution but getting the same result. Still no success. 

When I add -Dsoapui.https.protocols=TLSv1.2 onto SoapUI-5.3.0.vmoptions file in SOAP UI installed folder and try to save, it is giving me option to save it in document folder as .txt file and not as .vmoptions file
I have tried this step multiple times, but unable to find resolution to the same. 
Here is the screenshot:
User-added image

I transferred text file onto bin folder and tried to run login command under Soap UI 5.2.1 but getting again TLS 1.0 error. I tried deactivating the TLS 1.0 update from critical update and tried agian but no success. 

Regards
Chetan
Satya JaragSatya Jarag
Hi Chetan,

I think you dont have Admin Rights to access folders. Contact to person who will help you to get Admin permissions to your system.
Once you get that try with same steps again.

Thanks,
Satya 
Chetan KapaniaChetan Kapania
Hi Satya,

I am the standalone user on my laptop. So, bit confused as to from where I can update settings in order to get Admin Rights to access folders.

Regards
Chetan
Benedict SefaBenedict Sefa
Hi Everyone,
I noticed that the full stop is needed on the account description text. It might sound trivial but it helped me :-)
Grace WoodsGrace Woods
Hello. I get this far and would appreciate any tips:

Now we’re all set to make SOAP API requests. Full sail ahead, cap’n!
Log In to Your Trailhead Playground

Then I don't see how to do this:
In SoapUI, scroll down to the login operation. 

How do I get to SoapUI? Can anyone attach a screenshot of what that looks like from the Playground screen?
Thomas AlainThomas Alain
Hey Grace, 

SoapUI is a separate program you have to download. Just google Soap UI and it should be the first result
Nidhi PathariaNidhi Patharia
Hi,

I know it is an old question, but I cam across the same problem and after I found the problem I thought of putting it here, so that someone else could be benefitted.

The problem is for the challenge when you launch a playground make sure:
You generate the wsdl for the playgorund.
Copy the username from the settings. It will not be same as your email id like abc@gmail.com, it is similar to something like abc@brave-moose-348471.com
Request a new token from the playgorund if you don't already have it.
After you make sure you have completed the above steps follow the tutorial with the login credentials you get from the above steps and then copy the session id generated as a response from this and then the endpoint url for the account -> create is the domain name of your playground for eg: https://brave-moose-348471-dev-ed.my.salesforce.com/services/Soap/c/xx.0 xx is the version no of your api.

I hope this helps!
yanmei zhouyanmei zhou
Hi Nidhi,

Could you advice how to do "endpointurl" for the account? I got following error message after request for "Create Account".

"<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:sf="urn:fault.enterprise.soap.sforce.com" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <soapenv:Body>
      <soapenv:Fault>
         <faultcode>UNKNOWN_EXCEPTION</faultcode>
         <faultstring>UNKNOWN_EXCEPTION: Destination URL not reset. The URL returned from login must be set in the SforceService</faultstring>
         <detail>
            <sf:UnexpectedErrorFault xsi:type="sf:UnexpectedErrorFault">
               <sf:exceptionCode>UNKNOWN_EXCEPTION</sf:exceptionCode>
               <sf:exceptionMessage>Destination URL not reset. The URL returned from login must be set in the SforceService</sf:exceptionMessage>
            </sf:UnexpectedErrorFault>
         </detail>
      </soapenv:Fault>
   </soapenv:Body>
</soapenv:Envelope>"


Thank you,
May
Nidhi PathariaNidhi Patharia
Hi May,

Could you login and get the session id?
yanmei zhouyanmei zhou
Hi Nidhi,
I can log in and get the session id. The challenge I faced is I don't know where to update the change the Endpoint as adviced by the Trailhead module for "Create Account". Finally, figure it out as following. 
1. Get the base URL from sites, like http://na##.salesforce.com/services/Soap/c/43.0/
2. I change the http://login.salesforce.com/service/Soap/c/43.0/Packagecode(on the SOAP UI) to http://na##.salesforce.com/services/Soap/c/43.0/ under the Create Request UI window, and it works finally.
Also share as following screen shot, just in case if any other users have similar confusion regarding URL reset for this step.
User-added image
Thank you,
May Zhou
Shweta SoparkarShweta Soparkar
I was facing the same issue, it was erroring out with not logged in using SOAPUI, Remove the 
<urn:LoginScopeHeader>
         <urn:organizationId></urn:organizationId>
         <!--Optional:-->
      </urn:LoginScopeHeader>


from the header.It worked for me!
Jorge Antonio Peña Piña 9Jorge Antonio Peña Piña 9
Hello, my solution was, when creating the name of the account and the description to remove the quotes, in the description to take care that it takes the final point and ready, I hope it helps them
Angel Esau Vazquez LagosAngel Esau Vazquez Lagos
Yo tengo ese problema y no sé a que se debe :S 
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns="urn:enterprise.soap.sforce.com" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <soapenv:Header>
      <LimitInfoHeader>
         <limitInfo>
            <current>18</current>
            <limit>15000</limit>
            <type>API REQUESTS</type>
         </limitInfo>
      </LimitInfoHeader>
   </soapenv:Header>
   <soapenv:Body>
      <createResponse>
         <result>
            <errors>
               <message>La regla de validación SOLO debe aplicarse a los registros de contacto con una cuenta asociada. Los registros de contacto sin una cuenta principal asociada se pueden agregar con cualquier valor de MailingPostalCode.</message>
               <statusCode>FIELD_CUSTOM_VALIDATION_EXCEPTION</statusCode>
            </errors>
            <id xsi:nil="true"/>
            <success>false</success>
         </result>
      </createResponse>
   </soapenv:Body>
</soapenv:Envelope>
Andrew Fisher 19Andrew Fisher 19
I am getting this error when trying to create the account:
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
   <soapenv:Body>
      <soapenv:Fault>
         <faultcode>soapenv:VersionMismatch</faultcode>
         <faultstring>The SOAP request must use SOAP 1.1, did not recieve a SOAP 1.1 Envelope as the document root</faultstring>
      </soapenv:Fault>
   </soapenv:Body>
</soapenv:Envelope>

I can login sucessfully, just cannot get around this error

Any help would be much appreciated
Dharshini D 1Dharshini D 1
I am not able to create the account...
please someone check my code

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:urn="urn:enterprise.soap.sforce.com" xmlns:urn1="urn:sobject.enterprise.soap.sforce.com">
   <soapenv:Header>   
      <urn:SessionHeader>
         <urn:sessionId>00D2x000002yvFf!ARYAQIRzVOQMfwTIclLQcjnQ8UEmrEISpX4wceiXQzDe1W7GA3Xznh94Vq0_gIi3cc2eNRPWzH.fXH6XxkGy_t300q9fGhBn</urn:sessionId>
      </urn:SessionHeader>
   </soapenv:Header>
   <soapenv:Body>
      <urn:create>
        <urn:sObjects xsi:type="urn1:Account" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

         <Name>Bluebeards Grog House</Name>
         <Description>It is better than Blackbeards.</Description>
         </urn:sObjects>
      </urn:create>
   </soapenv:Body>
</soapenv:Envelope>



Output window:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns="urn:enterprise.soap.sforce.com" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <soapenv:Header>
      <LimitInfoHeader>
         <limitInfo>
            <current>15</current>
            <limit>15000</limit>
            <type>API REQUESTS</type>
         </limitInfo>
      </LimitInfoHeader>
   </soapenv:Header>
   <soapenv:Body>
      <createResponse>
         <result>
            <errors>
               <message>Check State</message>
               <statusCode>FIELD_CUSTOM_VALIDATION_EXCEPTION</statusCode>
            </errors>
            <errors>
               <message>Check state</message>
               <statusCode>FIELD_CUSTOM_VALIDATION_EXCEPTION</statusCode>
            </errors>
            <id xsi:nil="true"/>
            <success>false</success>
         </result>
      </createResponse>
   </soapenv:Body>
</soapenv:Envelope>
Mohammed Faizan 3Mohammed Faizan 3
Hello.
I'm stuck in completing this challenge: create an account using SOAP API and SoapUI
After saving wsdl xml file, after entering correct username and password+security token. Im still not getting sessionid. Here is the screenshot User-added image
Plz help me with this
Thank you in advance.
Lukesh KarmoreLukesh Karmore
My error is...
Challenge not yet complete in trailhead playground 5
Could not find an account named 'Bluebeards Grog House' created using SoapUI with the Description 'It is better than Blackbeards.'
Can any one let me know what's the problem...i did it properly..
Lukesh KarmoreLukesh Karmore
i complete the challenge by simple method-
used your username  properly ,open playground starter  you get it.
write the name and description without commas and fullstop is required.
thank you.

 
Shereena TShereena T
Worked for me.

 Request:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:urn="urn:enterprise.soap.sforce.com" xmlns:urn1="urn:sobject.enterprise.soap.sforce.com">
   <soapenv:Header>
      <urn:SessionHeader>
         <urn:sessionId>00D4P000000y1Cx!ARIAQLicRIXOUzsiwxX8Bx8bm2fvzuqMDlLpe.NUl6hBW_okQsULZ3NjCwmDfDn.mUK5COUc5e74.Yqs2WlNFuqdAuWqeO9n</urn:sessionId>
      </urn:SessionHeader>
   </soapenv:Header>
   <soapenv:Body>
      <urn:create>
         <!--Zero or more repetitions:-->
         <urn:sObjects xsi:type="urn1:Account" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <!--Zero or more repetitions:-->
            
            <Name>Bluebeards Grog House</Name>
            <Description>It is better than Blackbeards.</Description>
            <urn1:Id></urn1:Id>
         </urn:sObjects>
      </urn:create>
   </soapenv:Body>
</soapenv:Envelope>




Response:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns="urn:enterprise.soap.sforce.com">
   <soapenv:Header>
      <LimitInfoHeader>
         <limitInfo>
            <current>113</current>
            <limit>15000</limit>
            <type>API REQUESTS</type>
         </limitInfo>
      </LimitInfoHeader>
   </soapenv:Header>
   <soapenv:Body>
      <createResponse>
         <result>
            <id>0024P00003CaiNjQAJ</id>
            <success>true</success>
         </result>
      </createResponse>
   </soapenv:Body>
</soapenv:Envelope>