+ Start a Discussion
muneeswar umuneeswar u 

Visualforce page in community not visible to public users

Hi all,
I have an issue with displaying the VisualForce page to public users.
I have added the vf to the GuestUser profile , still it is not visible to public users.
Can someone help me by providing a solution. Thanks in advance.

Regards,
Muneeswar

Visualforce page in community, when user logged in.
User-added image 
Visualforce page in community, for public Users
User-added imagecan some one help me with this issue ?

 
VinayVinay (Salesforce Developers) 
Can you check below settings?

1.  Communities > Manage Communities > Force.com > Public Access Settings > Enable Visualforce Page Access.
2. Setup > Manage Users > Profile > Click on Profile Name > Visualforce Page Access.

Thanks,
Malika Pathak 9Malika Pathak 9
Hi muneeswar,

Greetings!

1. First go to Setup > Develop > Sites,
2. Next step register your Force.com subdomain name,
3. After that create a new Force.com Site
4. Next to ‘Site Visualforce Pages’ click Edit
5. Finally, add your page to the list of Enabled Visualforce Pages
Then fine. Now your page will be in public.

Please mark it as the best answer if it helps you to fix the issue.

Thank you!

Regards,
Malika Pathak