+ Start a Discussion
KoolABKoolAB 

Custom Font Imported as a static resource doesn't show up on Community

Custom Font Imported as a static resource doesn't show up on Community. We have selected Custom Font under Themes in community builder. When I do preview custom font is not shown.
We have followed all steps in the link mentioned below
https://developer.salesforce.com/docs/atlas.en-us.communities_dev.meta/communities_dev/communities_dev_customize_font.htm
The CSS is as follows 
@font-face {
font-family: 'TomTomFonts';
src: url('/enterprise/s/sfsites/c/resource/TomTomFonts/Gotham font/Gotham-Bold.otf') format('otf');
}


 
Best Answer chosen by KoolAB
KoolABKoolAB
Issue is resolved after using font format WOFF. It looks like salesforce.com doesnt support font format OTF

All Answers

Khan AnasKhan Anas (Salesforce Developers) 
Hi,

Greetings to you!

Please refer to the below links which might help you further with the above issue.

https://salesforce.stackexchange.com/questions/204695/custom-fonts-not-working

https://salesforce.stackexchange.com/questions/181792/setting-a-font-in-the-napili-template

I hope it helps you.

Kindly let me know if it helps you and close your query by marking it as solved so that it can help others in the future. It will help to keep this community clean.

Thanks and Regards,
Khan Anas
Raj VakatiRaj Vakati
Are you using the correct path from the static resource .. ??


https://developer.salesforce.com/docs/atlas.en-us.communities_dev.meta/communities_dev/communities_dev_customize_font.htm



 
KoolABKoolAB
Hi I am using correct path for static resource. Regards Abhijit
KoolABKoolAB
Hi Anas Thanks for your prompt response. I have tried solutions mentioned on threads below but doesn’t work in our environment. Please let me know if there is any way to debug or troubleshoot to find out the root cause of this issue Regards Abhijit
KoolABKoolAB
Issue is resolved after using font format WOFF. It looks like salesforce.com doesnt support font format OTF
This was selected as the best answer