+ Start a Discussion
Vandana Rattan 4Vandana Rattan 4 

System.HttpResponse[Status=Service Unavailable, StatusCode=503] while designing Custom Adapter for Salesforce Connect

I am trying to build a Custom Adapter for showing data in Salesforce at runtime using Salesforce Connect. Target DB is Oracle. Below is the error which I get when I try  to view data for the external object via a custom tab that I have built:

System.HttpResponse[Status=Service Unavailable, StatusCode=503]

Any suggestions on how this can be resolved?
Best Answer chosen by Vandana Rattan 4
Vandana Rattan 4Vandana Rattan 4
We had firewalss set which was causing this issue

All Answers

Khan AnasKhan Anas (Salesforce Developers) 
Hi Vandana,

Greetings to you!

Please verify the endpoint URL. Try the exact URL you are submitting in your Apex code by pasting it into a browser address bar. Assuming the exact URL works in your browser, double check that you've configured a Remote Site Setting for the URL inside of Salesforce.

Also, check whether you have white-listed salesforce IP's in their proxy:

https://help.salesforce.com/articleView?id=000321501&type=1&mode=1

http://www.salesforcegeneral.com/salesforce-articles/ip-whitelists-for-salesforce.html

Please refer to the below knowledge article which might help you further with the above issue.

https://help.salesforce.com/articleView?id=000313207&type=1

I hope it helps you.

Kindly let me know if it helps you and close your query by marking it as solved so that it can help others in the future. It will help to keep this community clean.

Thanks and Regards,
Khan Anas
Vandana Rattan 4Vandana Rattan 4
We had firewalss set which was causing this issue
This was selected as the best answer