+ Start a Discussion
Craig WoodmanCraig Woodman 

Navigation buttons stop working with Flow on Salesforce 1 app

Hi everyone,

I opened a case with Salesforce, and they suggested I post it here.  I have a flow that I developed that is used for a visitor log in on an iPad at a kiosk.  The flow asks for name, phone, nature of business, etc, and writes these to a "Visitor Log" object.  My plan is to incorporate with other elements as we go.

I run this flow with an iPad, running the Salesforce 1 mobile app.  I utilize Apple's guided functions, not allowing a click in areas that they don't need to be clicking in the Salesforce 1 app.  All was working well at first, but the flow will stop working after a time period.  Specifically, the flows navigation buttons stop working.  You can still click in the screen and edit, but the navigation buttons stop advancing or going back.

After trying all of the standard things (restart iPad, hard reset, etc.), as
I was using a custom flow screen component for navigation buttons, so I figured maybe that was the issue.  I removed the FSC, and went back to standard navigation buttons.  The issue persists.  It is usually after several hours, and makes it unusable for the purpose.

I solved the problem by removing all lightning components from the flow (ugh... visually bad!) and distributed the flow inside of a visual force page, and through a salesforce site.  No problems at all.  The flow continues to function even after several weeks.  I am still using the Guided functions on the ipad to prevent navigation off of the page.

If I could use the lightnging screen components and deliver the flow in lightning run time doing this, I consider the problem solved!  But I can't.  I opened a case with Salesforce, and they said that the issue was with flows, so I needed to post here.  I don't think that it is, because the flow is functioning perfectly inside of the VF page on a Salesforce Site.

Anybody have any ideas on why this could be?
Khan AnasKhan Anas (Salesforce Developers) 
Hi Craig,

Greetings to you!

I tried to research your problem and found that this is a known issue. Keep watching this issue until get fixed.

https://success.salesforce.com/issues_view?id=a1p3A0000018NtlQAE

You can select the 'This Issue Affects Me' button to report your account and receive updates.

Update from Salesforce:
On iOS devices $A.util.isEmpty(requiredComponents) returns false when it should return true as in one.app or Android devices, and that's why navigation does not happen on iOS devices. 
The R&D team has notified of this issue. they are currently testing to fix the issue and determining the tentative fix for this issue.

I hope it helps you.

Kindly let me know if it helps you and close your query by marking it as solved so that it can help others in the future. It will help to keep this community clean.

Thanks and Regards,
Khan Anas
Craig WoodmanCraig Woodman
Thank you so much!  I spent quite a bit of time searching and did not come up with that one.  I appreciate your help!

Craig
Craig WoodmanCraig Woodman
A couple of things on this one... I don't see a "This affects me" button on here.

Second, upon reading more closely on the referenced page, this may not completely describe what is happening.  

Summary
Flow action that leverages embedded Lightning Component code bundles is not functioning on iOS-based contexts--hybrid app and on Safari mobile browser. Custom flow navigation solution written with Lightning Components are not firing.

The problem here is two fold.  First, this is not a "custom" flow navigation solution.  The problem occurs with the custom solution I installed, but I removed the custom solution, and the flow still will stop responding with the native Salesforce flow buttons.  

Second, the summary makes reference to not functioning on the Safari mobile browser.  My workaround for this has been to deliver this flow through a visualforce page, and then with a Salesforce Site.  To do this, I had to remove all of the lightning components from the flow (which renders it pretty ugly, as I was using images and some screen elements.  If I could deliver the flow this way, and keep the lightning components, the problem is solved (and in a better way, because I don't have to use a license to get this to work!)  But this version with the Visual Force page has been running for a few weeks now, with no locking up, and it runs with the Safari mobile browser.

Perhaps there is a way to deliver a flow, with lightning run time, through a simple website that can be accessed without a login, like a Salesforce site?

Thanks in advance for any help!

Craig