+ Start a Discussion
Somya TiwariSomya Tiwari 

Default Value for Picklist not Working

I have set Default value for a Picklist, but to my luck it is not working, don't know the reason for the same.

Can anyone help me with any workaround? Even Custom Picklists are not working with default values on Account. Although it is working for Contact. 

Default Value:
User-added image

New Account Page:
User-added image
 

Best Answer chosen by Somya Tiwari
Khan AnasKhan Anas (Salesforce Developers) 
Hi Somya,

Greetings to you!

You have record types enabled for Account. Each record type has its own Default. You have to set the default under each record type. 
Go to Setup -> Object Manager -> Account -> Record Types -> Open Record Type - Not Edit -> Picklist value to set default

I hope it helps you.

Kindly let me know if it helps you and close your query by marking it as solved so that it can help others in the future. It will help to keep this community clean.

Thanks and Regards,
Khan Anas

All Answers

Khan AnasKhan Anas (Salesforce Developers) 
Hi Somya,

Greetings to you!

You have record types enabled for Account. Each record type has its own Default. You have to set the default under each record type. 
Go to Setup -> Object Manager -> Account -> Record Types -> Open Record Type - Not Edit -> Picklist value to set default

I hope it helps you.

Kindly let me know if it helps you and close your query by marking it as solved so that it can help others in the future. It will help to keep this community clean.

Thanks and Regards,
Khan Anas
This was selected as the best answer
n_pavan_kumar1n_pavan_kumar1
hi, this solution worked.. thanks for sharing!