+ Start a Discussion
Su Wang 17Su Wang 17 

Other languages causes restricted picklist error

Hi, all:
We have a user who uses Portuguese as his language on the Salesforce platform. When he tried to update a record, he ran into the following error:
Não é possível salvar esse registro porque o processo "Create Spread On Multi Office Upsert" falhou. Forneça ao seu administrador do Salesforce estes detalhes. An Apex error occurred: System.DmlException: Insert failed. First exception on row 9; first error: INVALID_OR_NULL_FOR_RESTRICTED_PICKLIST, Reporting Month(pl): valor incorreto para campo de lista de opções restrita: AGO: [Reporting_Month_pl__c] ID do erro: 151573068-11015 (765253783)

The root cause of it is due to in Portuguese language, AUG (August) is AGO which is not on our restricted picklist "Reporting Month(pl). We don't want to relax the restricted list.

Has anyone encountered similar issue with a walk-around solution?

Thanks!
​​​​​​​

Su

ShirishaShirisha (Salesforce Developers) 
Hi Su,

Greetings!

Can you please try the workaround suggested in the below article:

https://help.salesforce.com/articleView?id=000338433&language=en_US&type=1&mode=1

Otherwise,you can enable the Translations which will allow the users to translate the values automatically.

https://help.salesforce.com/articleView?id=wcc_setup_enable_translation.htm&type=5

Kindly mark it as best answer if it helps so that it can help others in the future.

Warm Regards,
Shirisha Pathuri
Su Wang 17Su Wang 17
Hi, Shirisha, glad that you have pointed me to these directions.  But I don't think I fully understand the difference between "end-user language" and "platform-only language" after reading the articles several times.  So, I don't know which one we should enable.

Our company's default language is English. And I see the user picked language "Portuguese (Brazil)" is a fully supported one. In order to avoid the "Bad Value for restricted picklist" error, which one should we enable?

And under what circumstance, should we enable "Translation Workbench"?

Thanks for your help!

Su
Su Wang 3Su Wang 3
Hi, Shirisha:

I have tried on our sand box with enable one of the language settings or both: Enable end-user languages and Enable platform-only languages; enable translator workbench, but the error due to the foreign language persists.

Thanks!

Su
Sam G 25Sam G 25
Hi Su,
I am facing exact issue. Would you help me if you resolved yours?