+ Start a Discussion
Frank van den DungenFrank van den Dungen 

Stuck on Quick Start: Lightning Web Components

Hello,

I'm in the 3rd unit of the Quick Start: Lightning Web Components module where you have to create a Hello World LWC. I have done all steps and the code works (I see the Hello World component on the Homepage in the Playground), but the Verify Step at the end keeps failing with the message:
Step not yet complete in My Trailhead Playground
Make sure you add the 'helloWorld' Lightning web component to the default Home page.

I have deleted the playground and created a new one. I deleted all code and started from the beginning again, but still no success. This is driving me crazy. What is going on?

Can someone help?

Frank
 
Khan AnasKhan Anas (Salesforce Developers) 
Hi Frank,

Greetings to you!

Make sure that the API name matches perfectly and the home page you added it to is set as the default.

1. Delete the newly created Home Page.
2. Re-edit System default home page.

I hope it helps you.

Kindly let me know if it helps you and close your query by marking it as solved so that it can help others in the future. It will help to keep this community clean.

Thanks and Regards,
Khan Anas
Frank van den DungenFrank van den Dungen
That would be too simple, but I'm 100% sure these are correct.

Frank
Frank van den DungenFrank van den Dungen
3rd attempt, deleted everything (both code and playground) and started from scratch again. But still no success. Why oh why?

User-added image
Frank van den DungenFrank van den Dungen
Well, I finally managed to succeed (sort of). Instead of creating a new playground I took an old one and authorized the project in vsc to it. I didn't change anything in the code. I deployed to the old playground, added the component to the sales page, etc. And now the module verified successful. Looks like it refuses to work in newly created playgrounds.

Colleague of mine tried the same with a newly created playground and also got an error. He did the same in an older playground and there it verified fine.

Seems like the trailhead module isn't properly verifying against new created playgrounds.
Shikha Jaiswal TamanShikha Jaiswal Taman
hi Frank,
Were you able to fix this? 
a fix by Tyrone {!Ty} Davis has worked for me and many. https://success.salesforce.com/answers?id=9063A000000eNeLQAU
There could be multiple home pages with name "Home Page Default" in your org and that confuses you to use the correct one.So you must delete the additional ones (setup > lightning App Builder > Home_Page_Default1 or Home_Page_Default2 and so on). Keep only Home_Page_Default in your org and then edit it to add the custom lwc. This should pass the challenge. 
 
Sanne Kjær Sørensen 3Sanne Kjær Sørensen 3
Thank you for this question. I got the a problem "deploy source to org" this works for Apex- not this. I tried 5 different sandboxz, 5 years old or totally new. I got this error:
-- json --loglevel fatal
--json --loglevel fatal ended with exit code 1
 i udpadeted both SDK to open source and reinstallerd the Salesforce CLI :-) can ypu help me in any direction?
Thank you in advance.
BR. SAnne
Mahi Dodani 13Mahi Dodani 13
On My Trailhead Playground oug I realized Home Page named as Home Page Default with API name as Home_Page_Default was missing. I created a Home Page with this name to verify the step successfully
Richard Fosu 12Richard Fosu 12
Mahi's Approach is the answer, I experienced Franks' issue and so I created the "Home Page Default" version using the standard homepage template and it worked immediately. It seems new playgrounds don't have this name label in place.
Pranav Gupta 28Pranav Gupta 28

"Seems it is dependent on Home Page Default" Mahi's solution worked for me also.

Tarun Bakhru 3Tarun Bakhru 3
spent hours trying to fix this. thanks Mahi
vanamamuralivanamamurali
thank you so much @Mahi Dodani 13
krithika goud 1krithika goud 1
Thank you so much @mahidodani13 , I spent hours fixing this but I couldn't bu just after changing name it worked out.
Sangeetha RajasekaranSangeetha Rajasekaran
Go to Setup-->Home--> Enable Home page default.
It worked for me.
Sangeetha RajasekaranSangeetha Rajasekaran
@mahi your solution helped me to clear this badge... Thank you so much
Ashrafali NagatiAshrafali Nagati
@Mahi Dodani 13 Your Sloution Worked for me also, thank you .

i Suggest to try this on out ....
RAVINDERREDDY KAMBALAPALLYRAVINDERREDDY KAMBALAPALLY
Thank you Mahi Dodani 13,
Creating Home Page, with Home Page Default worked. The trailhead environment has Sales_Home as its default page for home, So created a new home page with name Home Page Default.
Lara BrennanLara Brennan
Thank you Mahi DAAAohani13 solution is work for me 
i am tring to make on my site https://apkadviser.com/another-eden-apk (https://apkadviser.com/another-eden-apk/)/
 
Veronin SkadvizVeronin Skadviz
This is really detailed any it helps to uderstand this well

https://aginjector.xyz/
prakhar kumar 10prakhar kumar 10
Try Mahi approach. From setup, go to Lightning App Builder, First, remove the current page assignment and then clone the current page and change the name from example-"xyz" to Home Page Default of the page. Assign this one to org default and you r good to go.
Frank van den Dungen 14Frank van den Dungen 14
Hello all,

I appreciate the answers, but the question is over 2 years old and the issue has been solved a long time ago. Since you are still responding I get notifications about it.

Frank
Tonu Pramanik 10Tonu Pramanik 10

Hi All,
I want to share my personal experience in earning the 25 points for deploying  "helloWorld" in  LWC.

I find it very shameful that the easiest steping program in LWC where a simple word " HelloWorld " cannot be deployed due to watever issues I had. after trying for more than three days, with all the answers and forums that I could go through I failed everytime ,but I finally decided to create an ORG thinking this as an alternative.
So the three vertical dots that you see before LAUNCH. Hit on them and create a new playground.
The movement you are done with the new PLAYGROUND please note the username , coz that will be new and unique with hell lot of combinations.

You would need the username , when you Authorize your ORG.
Go to VS code. ctrl+shift+P and select the Authorize an ORG option.
Click Project default - and paste your user name.. the VS code should be able to find out the newly created ORG.
once you see that the ORG is connected. PUSH the changes for the helloworld that you have created.
Go to your ORG , Hit Applications--> Sales--> the page opens ---> hit setting gear icon---> edit ---> see the Custom Helloworld is now created-->drag and drop on the top of the builders page layout--> hit Save--> Activation POps--> activate--> save again. --. get back to trailhead page and complete the earning..

I hope this will help. 

NOTE: nothing changed in this process other then creating a new ORG and connecting the same to the VS.

Thanks
Tonu 


 

Noel HernándezNoel Hernández
IF YOU ARE DOING IT IN SPANISH:

CHange the homepage name to Home_Page_Default