+ Start a Discussion
Rick Paugh 3Rick Paugh 3 

Disabling Cache During Lightning Development

Is possible to disable cache during Lightning Component development?  I'm running into an issue where I've fixed a bug, but keep getting the error when I test.  And I know it's a caching issue because the error is on line number 29, but my component only has 24 lines of code.  I've tried disabling cache in the org and refreshing the web browser without cache.  Are there any other options available to ensure every time I load a Lightning component I'm getting the latest code?
Best Answer chosen by Rick Paugh 3
Rick Paugh 3Rick Paugh 3
I found the issue using the browser's developer console.  There was an deeper error that Salesforce was incorrectly presenting as "action not found".  Once this error was addressed, it began working.

All Answers

Rick Paugh 3Rick Paugh 3
Update:  I wiped all browser cache and even tried a different browser but still get the error, so the issue is definitely that Salesforce is caching the component and won't refresh it for some reason.
Raj VakatiRaj Vakati
Go to session settings an disable "Enable secure and persistent browser caching to improve performance" this

User-added image
Rick Paugh 3Rick Paugh 3
I tried that as well.  No luck.
Raj VakatiRaj Vakati
I dnt have any options to say .. but are you using Caching Service ??
Krishna.AvvaKrishna.Avva
Hi Rick,

Try the second step too in this article. https://medium.com/salestrip/salesforce-lightning-component-caching-a39b6a9d01a7

Regards,
Krishna Avva
Rick Paugh 3Rick Paugh 3
I found the issue using the browser's developer console.  There was an deeper error that Salesforce was incorrectly presenting as "action not found".  Once this error was addressed, it began working.
This was selected as the best answer