+ Start a Discussion
Nicola GrisctiNicola Griscti 

multiple roots found error?

I keep getting the following error
Lightning Web Component Bundle  LWC1075: Multiple roots found

Whenever I try to deploy/push source to my scratch org. I don't know why.. anyone else experienced this? I am not sure what it means by multiple roots, I haven't found any duplicate or multiple anythings.
Raj VakatiRaj Vakati
Even i am not sure about this error message .. 

Can you do one think .. 
  1. Do SFDX pull with source forceoverwrite 
  2. then try to push it again .. using SFDX push forceoverwrite 
Nicola GrisctiNicola Griscti
thank you for the suggestion, i just tried that.. and i am afraid that does not work :-( same error/s. i even tried recreating the component as a dummy component, and removing bits of code I was somehow able to get rid of the error for the dummy component, which has the same code just called dummhycomponent. So now.. I am just identifying the exact bit of code which was incorrect... by slowly putting back bits of the original code.
Aleksey SheldagaevAleksey Sheldagaev
Most likely you have some error in markup of template file, check all <template> tags within all template files of modules and ensure that each open-tag has his close-tag
keyla hernandezkeyla hernandez
In my case, it was because I needed to add a <template> tag
<template> <!-- this -->
<template if:true={isLoading}>
</template>
<template if:false={isLoading}>
</template>
</template> <!-- and this -->