+ Start a Discussion
MC34MC34 

HTML font support for default email signature.

Hi there,

I have tried several avenues to get this done right. However, Salesforce is not rendering the correct font type for the default signature on the Salesforce emails. I do not see any document where it says that certain fonts on HTML are not supported. Please provide if there is any. 
 
<style>
body {
  background-color: White;
  text-align: Left;
  color: Black;
  font-family: Century Gothic;

}
</style>
</head>
<body>

<b>Fincher</b>
<b>Salesforce Administrator</b>
ABC COMPANY<br/>
Tel.: (1) 000000000
Fax: (1) 000000000
Mobile: (1) 000000000
<a href = "mailto: FINCHER@abc.COM"> FINCHER@abc.COM</a>
<a href="https://www.ABC.com/US/">www.ABC.com</a></br>

<b>CONFIDENTIALITY NOTICE</b>
<small>This electronic message is confidential and may contain legally privileged information intended only for the use of the individual or company named above. If the reader of this message is not the intended recipient, or the employee or agent responsible to deliver it to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communications is strictly prohibited. If you have received this communication in error, please immediately notify us by telephone, and return the original message to us at the address above.</small>


</body>
Century Gothic font is not rendering as it is showing in the code. 

Here is what is showing: 

User-added image

Thank you, 
Fincher
Best Answer chosen by MC34
e_line_lin
Hi Fincher,

Use this HTML instead. If you have a link, make sure to not nest a span tag inside of the <a> tag, because that will mess with your styling of the link itself.

<a href="http://fincher.com" style="text-decoration:none;color:#ffc107;font-size:18px;font-family:Source Sans Pro Black,sans-serif;">Fincher.com</a><br />
<span style="font-size:10px;color:black;line-height:.7;font-family:'Source Sans Pro',sans-serif;">It's all there!</span>
<p>&nbsp;</p>
<span style="font-size:10px;line-height:.7;font-family:'Source Sans Pro',sans-serif;color:black;font-weight:bold;">CONFIDENTIALITY NOTICE<br />
<span style="line-height:107%;font-family:'Source Sans Pro',sans-serif;color:black;">This electronic message is confidential and may contain legally privileged information intended only for the use of the individual or company named above. If the reader of this message is not the intended recipient, or the employee or agent responsible to deliver it to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communications is strictly prohibited. If you have received this communication in error, please immediately notify us by telephone, and return the original message to us at the address above.</span></span>

All Answers

AbhishekAbhishek (Salesforce Developers) 
Hi Fincher,

The below article,

https://help.salesforce.com/articleView?id=000324370&type=1&mode=1

Explain about "Email template does not display correctly in Outlook or other email clients" 

An Idea is raised for "Default Fonts and Colors for Emails"

https://trailblazer.salesforce.com/ideaView?id=08730000000Xt5cAAC

Check it once.

I hope you find the above information is helpful. If it does, please mark as Best Answer to help others too.

Thanks.
MC34MC34
@Abhishek - Thanks for the reply. However, to be more precise the issue is wioth . This is the signature for the users where they go to their Personal setting --- Emil settings -- signature 
AbhishekAbhishek (Salesforce Developers) 
Then You can raise a case with the Salesforce support team so that they can check the background of it and let you know.
e_line_lin
Hi Fincher,

I'm an email developer and can explain why you're not seeing the font render as Century Gothic. Is the image you have shown by chance from an Outlook rendering of the email signature? Unfortunately, Century Gothic is not a universally supported web font. There's a difference between web fonts and web safe fonts. Fonts such as Arial and Verdana are "web safe" meaning they're default built into systems/devices and are considered universal fonts. Pretty much any device or email client will show those as intended. Century Gothic is going to be considered a web safe font, which means it won't be displayed consistenly across devices/email clients. You can purchase the Century Gothic font and import it into your email. However, Outlook desktop app on a Windows computer, as well as Gmail, do not support web safe fonts, even if they're imported. So you'll see their default fonts (Times New Roman for Outlook, Trebuchet MS for Gmail) displayed, as opposed to the imported font. I'd recommend using an universal font, Arial being my favorite.

Thanks.
MC34MC34
Hi
e_lin, 

Thanks for the message. Yes I am now able to convince the users to go by the universal fonts. However, there is another problem I am getting into and that is under the company's website there is this blue line I wish to get rid of. However, if I use CSS stylesheets with HTML code it is going to make the file size big. I want to keep is low in lightning letterhead. Do somebody know how to get rid of blue like such as this: 

User-added image

Code I am using this this: 
 
<a href="http://fincher.com"><span style="color:#ffc107;font-size:18px;font-family:Source Sans Pro Black,sans-serif">Fincher.com</span></a><br />
<span style="font-size:10px"><span style="color:black"><span style="line-height:.7;font-family:&quot;Source Sans Pro&quot;,sans-serif"> It&rsquo;s all there!</span></span></span>
<p>&nbsp;</p>
<span style="font-size:10px"><b><span style="line-height:.7;font-family:&quot;Source Sans Pro&quot;,sans-serif;color:black">CONFIDENTIALITY NOTICE</span></b><br />
<span style="line-height:107%;font-family:&quot;Source Sans Pro&quot;,sans-serif;color:black">This electronic message is confidential and may contain legally privileged information intended only for the use of the individual or company named above. If the reader of this message is not the intended recipient, or the employee or agent responsible to deliver it to the intended recipient, you are hereby notified&nbsp; that any dissemination, distribution or copying of this communications is strictly prohibited. If you have received this communication in error, please immediately notify us by telephone, and return the original message to us at the address&nbsp;above.</span> </span>

Thanks for the help. 

Fincher
MC34MC34
The code: text-decoration: none; 

does not work
e_line_lin
Hi Fincher,

Use this HTML instead. If you have a link, make sure to not nest a span tag inside of the <a> tag, because that will mess with your styling of the link itself.

<a href="http://fincher.com" style="text-decoration:none;color:#ffc107;font-size:18px;font-family:Source Sans Pro Black,sans-serif;">Fincher.com</a><br />
<span style="font-size:10px;color:black;line-height:.7;font-family:'Source Sans Pro',sans-serif;">It's all there!</span>
<p>&nbsp;</p>
<span style="font-size:10px;line-height:.7;font-family:'Source Sans Pro',sans-serif;color:black;font-weight:bold;">CONFIDENTIALITY NOTICE<br />
<span style="line-height:107%;font-family:'Source Sans Pro',sans-serif;color:black;">This electronic message is confidential and may contain legally privileged information intended only for the use of the individual or company named above. If the reader of this message is not the intended recipient, or the employee or agent responsible to deliver it to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communications is strictly prohibited. If you have received this communication in error, please immediately notify us by telephone, and return the original message to us at the address above.</span></span>
This was selected as the best answer
MC34MC34
thanks a lot! by the way, do you know what is the default font salesforce uses for the auto signature? 
e_line_lin
Glad it worked! I believe the Salesforce default font is Arial.