+ Start a Discussion
Yogesh BiyaniYogesh Biyani 

No package.xml found

I am trying to deploy changes to the States/Country picklist via workbench and it fails with "No package.xml found" message. I am not sure what I am doing wrong.  I am on mac and ensured that the folder __MACOS is not in the folder as suggested in this article. (https://medium.com/@wangyidan621/salesforce-workbench-zip-deployment-no-package-xml-found-error-on-mac-ec7ce49a7126)

Here is the link to the package (https://drive.google.com/file/d/1GSTb0aN0hv2TMTVi_I6AgkdaMPTqLVGS/view?usp=sharing)
User-added image
Best Answer chosen by Yogesh Biyani
Abhishek BansalAbhishek Bansal
Hi Yogesh,

The folder structure that you are trying to use is not correct. Your metadata components should be in a parent folder and than that parent folder should be zipped and deployed using workbench.
Please take the zipp folder from this link and than try to deploy it using workbench:
https://drive.google.com/file/d/13gI2ZSpTj-TdS8NbETx-ozfIOmx9fALh/view?usp=sharing

Please let me know if you face any issues with this.

Thanks,
Abhishek Bansal.

All Answers

ShirishaShirisha (Salesforce Developers) 
Hi Yogesh,

Greetings!

I was unable to access the drive link as the access has been restricted.However,I can provide you the possible causes for this as below:

When you try to zip the payload please make sure that the package.xml formatted in case sensitive.Also,can you please try by checking the checkbox which is single checkbox to make sure it checks for the actual checkbox,if more than one package.xml is included.

Kindly mark it as best answer if it helps so that it can help others in the future.

Warm Regards,
Shirisha Pathuri
Abhishek BansalAbhishek Bansal
Hi Yogesh,

The folder structure that you are trying to use is not correct. Your metadata components should be in a parent folder and than that parent folder should be zipped and deployed using workbench.
Please take the zipp folder from this link and than try to deploy it using workbench:
https://drive.google.com/file/d/13gI2ZSpTj-TdS8NbETx-ozfIOmx9fALh/view?usp=sharing

Please let me know if you face any issues with this.

Thanks,
Abhishek Bansal.
This was selected as the best answer
Yogesh BiyaniYogesh Biyani
Hello Abhishek,

Thanks for checking.  Updating the folder structure worked!  I must has missed that detail from the docs.

Yogesh
Yogesh Biyani 17Yogesh Biyani 17
@Abhishek I am unable to download the zip file. It says file is in owner's trash.