+ Start a Discussion
Natraj Subramani 15Natraj Subramani 15 

Azure DevOps - Salesforce ANT Migration Error

Hi All,

I initially got the CI/CD part working between Azure Devops and Salesforce sandbox. Whenever I push the code to DevOps branch, the build would automatically happen and trigger ANT which would use the variables like login url, password, username etc and deploy the latest code to specified Salesforce sandbox.


I was forced to change my Salesforce sandbox password and from then onwards the build is failing with below error. Though I can login into the Salesforce using the same username and password, ANT is still not recognizing my new password and throws the below invalid password error.


BUILD FAILED /home/vsts/work/1/s/build/build.xml:29: Invalid username, password, security token; or user locked out##[error]Error: The process '/usr/bin/ant' failed with exit code 1

##debug]Processed: ##vso[task.issue type=error;]Error: The process '/usr/bin/ant' failed with exit code 1 ##debug]Processed: ##vso[task.complete result=Failed;]Error: The process '/usr/bin/ant' failed with exit code 1 

User-added image

In the above screen shot, I see the correct username, login url and password displayed but still the invalid password error comes up.

When I check login history, this is what I see. Any help is appreciated.

User-added image

Any help is appreciated

Thanks
Natraj
 
Natraj Subramani 15Natraj Subramani 15
Hi All,

Got this working, had to change the build.properties values as well. The old password and security token was mentioned in it. For some reasons the values we specify during build is not taken.

Thanks
Natraj