+ Start a Discussion
Chris Brown 86Chris Brown 86 

Session-based permission sets trail issues

1. First issue I had was with step 'Get Started with Session Based Permission Sets'. The first two steps of the challenge say to:
  • Clone the Read Only profile and name it Read Only Clone
  • Create a user named Lynda Herman and assign the Read Only Clone profile to her.
I was not able to assign the new profile to that user. I think this might be a permission issue in the trailhead org I am using. Maybe a license issue or something.
I was able to complete the challenge with that user assigned to the 'Standard Platform User' profile.

2. In the second step of the trail - 'Activate Session-Based Permission Sets Without Code' - I had some more issues with assigning roles and permissions in the steps. In the middle of the step it says to:

Create a user who can edit and create contracts. This person is a hiring manager and needs access to employment contracts for contractors.
  • Assign the user to a profile, making sure that the person has read-only (no edit) access to the Contracts object. The person must run flows. For example, you could assign the user a clone of the read-only profile and enable the Manage Flow permission.
  • Assign the Employment Contracts Access permission set to the user.
- 'Manage Flow' doesn't seem to be a permission anymore. I think it might be called 'Flow User' now. Or I may be looking at the wrong thing.
- Again I wasn't able to assign the profile to the user I created.
- I also wasn't able to assign the permission set to the user. If I tried from the user, then the permission set wasn't in the list to add. If I tried from the permission set I got the following error:"The user license doesn't allow the permission: Delete Contracts". Same for Edit, Create or Read on Contracts. I tried some different user licenses but wasn't able to get it to work. I suspect this is a limitation of the trailhead org that I am working in and the licensing assigned to it.

3. In the 3rd steps of the trail I wasn't able to verify my steps since the user I created didn't have the correct profile or permission sets assigned. But I was able to complele the rest of the steps.

I was able to complete the trail since all the challenges were quizzes. I suspect they were changed to quizzes because of some of these issues so this may be a known problem.

Thanks,
-CaptCanada
Suchita Patil 16Suchita Patil 16
Please go through, below link..you'll get answer:-
https://trailhead.salesforce.com/en/content/learn/modules/session_based_perms/session_based_activate