+ Start a Discussion
Yashaswee NemmaniYashaswee Nemmani 

How to give Read Permission to Billing Address field on Account Object only for one user ?

If User's profile has not been given with any permission related to the field "Billing Address" on Account object. And the user is trying to query BillingCountry Field. He is facing with below error:

Error:
“INVALID_FIELD: No such column 'BillingCountry' on entity 'Account'. If you are attempting to use a custom field, be sure to append the '__c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names.”

I have tried to assign read permission to the user via existing permisison set which was created spectifically for this user purpose but "Billing Address" field is not listed in the object setting > account 

And strangly, this permssion seems like cannot be given via any profile of permission set it seems except from Field Level Security of the Billing Address field on account. Correct me if I m wrong here? but this is my observation.

So, do we have only one option to give permission to the user via field level security of the field? If Yes, this gives access to all the users of this profile but request is for only one user of this profil.

Please verify and guide me on how to proceed further on this requirement.

Thank you in advance.
OFröhlichOFröhlich
Hi,

please check again the permission set. There should be the field billing address. Maybe try to create a permission set with license type: salesforce.

If this helps, please mark as Best Answer to help others too.

Oliver
Yashaswee NemmaniYashaswee Nemmani
Hi Oliver,

Thank you for the reply.

Actually, the current one is a custom profile and created with license type: Salesforce and Billing Address field is not available under Accounts object.

Strangely, I m not even able to find this field on other Standard and Custom Permission sets under account object.

Not sure, if this is a standard functionality of salesforce or something else?

Thanks & Regards,
Yash