+ Start a Discussion
Ross ThanscheidtRoss Thanscheidt 

Verify Account asks for login information when signing up for Developer Edition org

I am in the Prioritize Leads with Einstein Lead Scoring project in Trailhead, trying to sign up for a Developer Edition org following these instructions (Step 1 takes you here (https://developer.salesforce.com/promotions/orgs/einsteinleadscoring)):

Instructions to sign up for a Developer Edition with Einstein Lead Scoring

Everything goes fine through Step 4, where I receive the e-mail, but when I click on the Verify Account link, I'm expecting it to take me to a page where I can set the password and enter a security answer, but instead it takes me to a login page (at login.salesforce.com) asking for a username and password, and it shows this error message even though I haven't tried to log in yet - Please check your username and password.  If you still can't log in, contact your Salesforce administrator.

Login page with error message


I can log in using my Salesforce production credentials, but it doesn't do anything.  I can't log in with the Username I signed up for a DE with (my-name@honeydew.com) because I haven't set my password yet.  I tried clicking on Forgot Your Password?, and received the e-mail with the link, but when I click on the link to reset my password, it asks for my favorite pet, which is a security answer I have not yet defined.

I have other training projects coming up with similar Create DE requirements, like signing up for an Einstein Prediction Builder Trailhead Playground, so I'd like to know how to successfully create and be able to log into a Developer Edition org.

What do I need to do?
wasim akram 42wasim akram 42
In our blog, Good Morning Images (https://goodmorningallimages.com/) you get a wonderful collection of Latest  Whatsapp Status, Good Morning Quotes, Motivational, Inspirational Quotes.
Romal SapruRomal Sapru
Hi Ross. I also faced the same issue with my FSC trial version. What I did is I removed all cookies and browser history and re-filled the form with same email address that I had filled before. As soon as I filled the form it direclty logged me into the system.
Bob MountBob Mount
This just happened to me try to sign up for a Dev org "with special configuration" for the Authentication Settings Superbadge.    It's the 3rd time this exact sequence of events has happened in my experience over the past 12 months.    Has Salesforce not addressed this, or offered a solution?