+ Start a Discussion
Michael MattiaccioMichael Mattiaccio 

Salesforce CLI Install Problems on MacOS Catalina

Hello,

I have tried multple different methods of installation of the Salesforce CLI to use in VSCode but I keep getting the error that it is not installed.

MacOS Catalina v10.15.4

VSCode:
Version: 1.44.2
Commit: ff915844119ce9485abfe8aa9076ec76b5300ddd
Date: 2020-04-16T17:07:18.473Z (1 wk ago)
Electron: 7.1.11
Chrome: 78.0.3904.130
Node.js: 12.8.1
V8: 7.8.279.23-electron.0
OS: Darwin x64 19.4.0

SFDX:
sfdx-cli/7.54.4 darwin-x64 node-v8.12.0

Here is a sample error log:
Starting SFDX: Create Project

14:14:08.906 sfdx force:project:create --projectname codeU --outputdir /Users/mike/Downloads --template standard
14:14:08.910 sfdx force:project:create --projectname codeU --outputdir /Users/mike/Downloads --template standard
 ended with error spawn sfdx ENOENT
Salesforce CLI is not installed. Install it from https://developer.salesforce.com/tools/sfdxcli

Printenv:

COLORFGBG=12;8
ITERM_PROFILE=Default
XPC_FLAGS=0x0
LANG=en_US.UTF-8
PWD=/Users/mike
SHELL=/usr/local/bin/zsh
TERM_PROGRAM_VERSION=3.2.3
TERM_PROGRAM=iTerm.app
PATH=/Users/mike/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin
COLORTERM=truecolor
TERM=xterm-256color
HOME=/Users/mike
TMPDIR=/var/folders/sj/qzxb0nfx0sz6wf4zn4482jrr0000gn/T/
USER=mike
XPC_SERVICE_NAME=0
LOGNAME=mike
__CF_USER_TEXT_ENCODING=0x1F5:0x0:0x0
SHLVL=1
OLDPWD=/Users/mike
ZSH=/Users/mike/.oh-my-zsh
PAGER=less
LESS=-R
LSCOLORS=Gxfxcxdxbxegedabagacad
LC_CTYPE=en_US.UTF-8
_=/usr/bin/printenv

First I tried installing the Salesforce Extension Pack https://marketplace.visualstudio.com/items?itemName=salesforce.salesforcedx-vscode

The I tried manual installation https://developer.salesforce.com/tools/sfdxcli

Neither worked. All of the support threads I found are for Windows. I cannot find where the CLI lives for me to add it as an environmental variable, if that is the problem.

Questions: 
1. What is the way to install the CLI so I can use it in VSCode?
2. What is the CLI path so I can add it to environmental variables?
3. What else am I missing?

Thank you all for your help.
AbhishekAbhishek (Salesforce Developers) 
Hi,

The below blogs might help you.

https://github.com/forcedotcom/salesforcedx-vscode/issues/1433

https://salesforcediaries.com/2019/03/15/salesforce-cli-and-visual-studio-code-command-palette/

https://www.sfdcstop.com/2019/06/how-to-setup-visual-studio-code-for.html

I hope you find the above solution helpful. If it does, please mark as Best Answer to help others too.

Thanks.

 
Michael MattiaccioMichael Mattiaccio
Hi Abhishek,

It's possible that the problem is I need to channge the PATH, but I cannot find CLI location on MacOS and all the posts are about Windows. Do you know where it lives on MacOS? Thank you for your time.
Bailey RuddBailey Rudd
I am having the same problem on Mac. 
Malika Pathak 9Malika Pathak 9
Hi Michael Mattiaccio
Please uninstall the new  CLI  and find the old version of it.
Thanks 
Hydrow asHydrow as
You can still try to add the different Email extension in your account. I have installed the upper system of Webemail in my website (https://webmailsguide.com/managed-internet-service-or-eq-webmail/).