+ Start a Discussion
Bablu Kumar PanditBablu Kumar Pandit 

How To fix This Issues INSUFFICIENT_ACCESS_ON_CROSS_REFERENCE_ENTITY:

We can't save this record because the “Opportunity Updates” process failed. Give your Salesforce admin these details. This error occurred when the flow tried to update records: INSUFFICIENT_ACCESS_ON_CROSS_REFERENCE_ENTITY: insufficient access rights on cross-reference id: a0G1U000003g8cd. You can look up ExceptionCode values in the SOAP API Developer Guide. Error ID: 1328276966-63986 (-2109863242)
VinayVinay (Salesforce Developers) 
Hi Bablu,

Check the user profile and check whether the user has access to insert/update that record. Even if the user has access, kindly check whether the user has access to update fields like record types, lookup field, master-detail field, etc.

Review below link which has more information on troubleshooting and checkpoints.

http://www.infallibletechie.com/2012/12/insufficient-access-rights-on-cross.html
http://sfdc2u.blogspot.com/2013/07/insufficientaccessoncrossreferenceentit.html

Hope above information was helpful.

Please mark as Best Answer so that it can help others in the future.

Thanks,
Vinay Kumar
David Zhu 🔥David Zhu 🔥
Process runs under the context of the running user, as the error suggested, it is a permission issue. You may use the following steps to resolve the problem.

1. Open Anoymous Window in Developer Console, run the script:
Id x = 'a0G1U000003g8cd';
system.debug('Object:' + x.getSObjectType().getDescribe().getName());

Open the log, and get the object name.

2. Get the profile of the user who experienced such error. Assign appropriate permission to the object which you found in step1. 
Bablu Kumar PanditBablu Kumar Pandit
Hii David,

i get object Name And when Go the Profile of  login user And where i  see All permission are Avilable on the object Lead_Scoring__c
David Zhu 🔥David Zhu 🔥
I guess this is happening on partial sandbox.
Can you try select id from lead_scoring__c where id ='a0G1U000003g8cd' to see if you can get the record.
Bablu Kumar PanditBablu Kumar Pandit
Hi David,

yes it happening in Sandbox org , I run above Query But no any Recode are avilable
David Zhu 🔥David Zhu 🔥
That is when data is sampled when creating Partial sandbox, not all records were copied over. In you particular case, Lead_Socring__c a0G1U000003g8cd was not copied over.
This is very common on Partial sandbox. 
You can go to this Opportunity and change the Lead_Scoring__c to an existing one. When you open this opportunity, you might see Lead Scoring field is in grey, it tells you corresponding lead scoring does not exist.
Bablu Kumar PanditBablu Kumar Pandit
when i open Opportunity And go to fileds where i see Lead_Socring__c  is the lookup so please tell me what we changed
David Zhu 🔥David Zhu 🔥
you need to change the value to an existing and valid lead_scoring__c record. or you can create a new lead_scoring record and assign to ths opportunity.
In summary, this is a data issue. 
Bablu Kumar PanditBablu Kumar Pandit
Hi David,
i am still facing this issues i do above step ,Now i have no ideas to solved this issues
David Zhu 🔥David Zhu 🔥
Another possiblity is access to  lead_scoring__c record is controller by role hierachy. If the record is created by the user higher than the running user in the role hierachy, it will also get such error.