+ Start a Discussion
Anil Rao 17Anil Rao 17 

Unable to add products in opportunity

I populated the standard Product Object with Products & activated all. I want to add some Products in the Opportunity Line Object via the standard Opportunity page. I am not seeing any Products when trying to add to the Opportunity or the Price Book.
PL. HELP!!!!
Best Answer chosen by Anil Rao 17
NagendraNagendra (Salesforce Developers) 
Hi Anil,

Sorry for this issue you are facing.

May I suggest you please check with if you have "Read permission on products and price books".

Below is the navigation using which you can enable the permission.

Profiles > User Profile group > Edit > Standard Object Permissions > Price books > Read access > Save

Also, Check the Opportunity.Product Page Layout Assignment settings, also check the Opportunity Line Item settings on your Opportunity Page Layout. 

Below is the navigation 

setup >> Quickfind >> Permission set >> Object Settings >> Product.
User-added image

For more information please refer to below link exactly with a similar discussion which might help you further. Hope this helps.

Kindly mark this as solved if the reply was helpful.

Thanks,
Nagendra
 

All Answers

NagendraNagendra (Salesforce Developers) 
Hi Anil,

Sorry for this issue you are facing.

May I suggest you please check with if you have "Read permission on products and price books".

Below is the navigation using which you can enable the permission.

Profiles > User Profile group > Edit > Standard Object Permissions > Price books > Read access > Save

Also, Check the Opportunity.Product Page Layout Assignment settings, also check the Opportunity Line Item settings on your Opportunity Page Layout. 

Below is the navigation 

setup >> Quickfind >> Permission set >> Object Settings >> Product.
User-added image

For more information please refer to below link exactly with a similar discussion which might help you further. Hope this helps.

Kindly mark this as solved if the reply was helpful.

Thanks,
Nagendra
 
This was selected as the best answer
Anil Rao 17Anil Rao 17
Got it. Thnx