+ Start a Discussion
Diane RoyerDiane Royer 

Flow Hitting Governor Limits

I am working on a Flow in Salesforce.  The flow worked perfectly in the Sandbox, but it is failing in Production.  I’m afraid I don’t understand the error it is giving me “Too many SOQL queries: 101”.  I’m not running SQL queries, I’m trying to run a flow.  I have run the flow a few times and get the same error each time.  I checked to make sure I am not running at the same time another task is running, so I am certain it is not because too many things are running at once.  Granted, the flow picked up a lot more records in Production than it did in my sandbox, but I don’t understand why that would be a problem.  The flow has been run as an administrator and a non-administrator.  I checked and there is a workflow rule involving some of the same fields that are in the Flow.  Could that be the problem?  If it could be, I don’t understand why the flow did not fail in the Sandbox (it has the same rules).  Something else that I noticed while working with these flows, is that in the Sandbox I now have Flow Builder and in Production I still have Cloud Flow Designer.  I don’t know if that has anything to do with the issues or not.   If it could, could you let me know what I need to do to get the Flow Builder in Production?  I do have two loops in my flow because there are two objects that need to be updated by flow and I don't know how else to accomplish this.  Any assistance you can provide would be greatly appreciated. 

 
nitin sharma 356nitin sharma 356
I am not sure but just check if there is any critical update related to flow interview has to be enabled  in your org.
Diane RoyerDiane Royer
Thank you for the suggestion.  Unfortunately, I just updated two critical updates that say they are related to flows, but I still get the same error message.  Here is a snapshot of the flow I set up.  Have I made a mistake here?  Is it alright to have a loop within a loop?  I did that because I am looking up customer records from multiple areas and if I tried to use the customer id number from the first loop in the second loop it couldn't find the id number outside the first loop.  Is there a better way to build this?
User-added image