+ Start a Discussion
Yathisha MedaYathisha Meda 

UNSUPPORTED_API_VERSION: invalid Api version specified on URL

Hello,
How should i rectify this issue, even i have changed the jdk path 
Raj VakatiRaj Vakati
Can u explain the when you are getting this error .. 

please refer this link 

https://help.salesforce.com/articleView?id=000263792&language=en_US&type=1


To correct this error, make the following changes in Workbench:
  • Hover over the Workbench label
  • Select 'Settings' in the dropdown
  • Change 'Default API Version' to one version lower. For example, if the selected API version is 40.0 and you are receiving this error, change the API version to 39.0.
  • Click 'Apply Settings' at the bottom of the page
  • Select the Workbench icon in the taskbar from your org again, and it should now behave as designed
  • Note: This option is saved in the browser cache. If you clear your cache or use an incognito browser, you will need to update this setting again.
Yathisha MedaYathisha Meda
Thank you for giving me a response,
I just had created a trail salesforce account and i have installed the sfdx in windows and visual studio code, when i am executing(SDFX:deploy source to org) the basic lightning web component in visual studio code am getting this error that invalid API version specified on URL
Yathisha MedaYathisha Meda
I even changed the API version and am getting the same issue
 
user905user905
Hi, I am getting the same issue. Any updates on how to resolve this issue.
Maya TulchinskyMaya Tulchinsky
Getting the same issue - any updates?
 
Maya TulchinskyMaya Tulchinsky
Here is solution that helped me with this error :  https://salesforce.stackexchange.com/questions/244080/sfdx-forcemdapiretrieve-giving-unsupported-api-version-invalid-api-version-s