+ Start a Discussion
anil Kumaranil Kumar 

Process Builder is not invoking Approval process

We have created process builder (BH_Delete Locations Assocation) on User Approval Object which invokes Approval Process when criteria meet. Below is the condition written in the builder. Process Builder is not invoking Approval process even condition meet. Suppose if we edit User Approval record and Click on Save at that time approval is getting created.

NOT(ISBLANK([BH_User_Approvals__c].Locations__c)) && NOT(ISBLANK([BH_User_Approvals__c].BH_UA_Business_Account__c)) && NOT(ISBLANK([BH_User_Approvals__c].User_Name__c)) && 
NOT(ISBLANK([BH_User_Approvals__c].BH_UA_Person_Account__c)) &&
ISPICKVAL([BH_User_Approvals__c].Location_Delete__c, 'Yes') &&   [BH_User_Approvals__c].BH_Approval_Ready__c = True

In the code level we are creating the user approval records for the approval purpose.

User-added image
Sainath VenkatSainath Venkat
@ anil

Did you check whether the approval process is active or not, also check if approval process have any entry criteria, if it has entry criteria, check whether the record is satisfying that criteria or not.

Hope it helps.
anil Kumaranil Kumar
@ Venkat

Yes Approval process is avtive and also approval process meets the  entry criteria. when i create User Approval record manully it creates approval.  When back end code creates User Approval record it is not automaticaly creating Approval Process.

Thanks,
Anil
Sainath VenkatSainath Venkat
@anil,

can you try to remove the entry criteria from approval process, instead mention entry criteria in process builder itself.