+ Start a Discussion
Shobha JamesShobha James 

How to set field level security

please help me ....

Two team members need to view and update Accounts, but only one should be able to see and edit the Rating field. Create one profile and one permission set with field level security to solve for this use case.The profile must be named 'Basic Account User' and result in an API name of 'Basic_Account_User'. It should use the 'Salesforce' user license type.
The permission set must be named ‘Account Rating’ and result in an API name of 'Account_Rating'.Check Challenge
Best Answer chosen by Shobha James
VamsiVamsi
Hi Shobha,

In Profile -> Object settings -> Account -> Uncheck both read and Edit for Ratting field 

In permission set -> Object settings -> Account> Field permissions -> Set rating field checked for Read and Edit.

Assign both to the single user . 

Thanks 
Vamsi

All Answers

Becky Chaffee 11Becky Chaffee 11
I am having problems making this one work also.
VamsiVamsi
Hi Shobha/Becky,

Set the below mentioned 

Profile level:
 On Account please check view and edit only.

In Field accessibility :
on Account object uncheck the Rating field from viewing and editing so that no user in that profile will view the field .

Now create a permission set Account Rating 
In permission set on field accessibility check both the check box for Rating filed to provide access to that field and assign to the single user to whom you want.

Please let me know If you find any difficulty in doing this ....!!!! . If you got this then please mark this as answer 

Thanks 
Vamsi
 
Shobha JamesShobha James
Hi Vamsi , Still I am confusing. They haven't mentioned which user should be able to see and edit the Rating field and who should not( there are many users). and could you please help me to explain step by step(I am a beginner) On Account object I am not able to check only view and edit(read is automatically checked and there is no view option -it's view all) And could you please help me to create permission set on Account Rating Thanks , Shobha
Shobha JamesShobha James
I am getting the error message :The 'Account Rating ' permission set did not have the appropriate field -level security for the Account Object
VamsiVamsi
Hi Shobha,

In Profile -> Object settings -> Account -> Uncheck both read and Edit for Ratting field 

In permission set -> Object settings -> Account> Field permissions -> Set rating field checked for Read and Edit.

Assign both to the single user . 

Thanks 
Vamsi
This was selected as the best answer
VamsiVamsi
Also set the Account object permissions to Read and Edit only. Don't set to View, view all or  modify all
Shobha JamesShobha James
Hi Vamshi, Thanks a lot ....it worked...I set object permission to Read only...I didn't assign to a single user that was the mistake I did . Thanks, shobha
Becky Chaffee 11Becky Chaffee 11
I have done all of this and I am still getting an error.
Danny Hallgren StLDanny Hallgren StL
Admin Trail - Intermediate Data Security Controlling Access to Fields

The is to speak to the error some may be getting:
"Challenge not yet complete... here's what's wrong:
The 'Account Rating' permission set did not have the appropriate field-level security for the Account object.

I think what this excercise is wanting to teach is that the profile should be more restrictive, and you use permission sets to open up more access, as opposed to the opposite way of thinking... which would be create a profile to allows everything, then use permission sets to disable access.

Here's how I passed the module:

Profile - Basic Account User
  • Create a new profile named 'Basic Account User' and set to use the 'Salesforce' user license type, just as specified
  • The field level security setting for the Basic Account User for account is setup so every field is marked 'Visible' and 'Read Only' is unchecked EXCEPT for the field 'Rating', for which nothing should be checked.
  • Assign this profile to an existing user or create a new user.

Permission Set - Account Rating
  • Create a new permission set named 'Account Rating', just as specified.
  • Object Settings -> Accounts:
Object Permissions Mark both  'Read' and 'Edit' and nothing else.
Field Permissions are setup so every box is checked including 'Read' and 'Edit' , including the 'Rating' field.
  • Assign this permission set to the user

This should get you the desired results. I hope this helps.






 
Hare Sudhan MuthusamyHare Sudhan Muthusamy
Thanks Danny Hallgren StL. It worked. 
Sandeep Mishra 7Sandeep Mishra 7
Hi Danny Hallgren StL,

Your answer is more descriptive. It worked liked champ !

Thanks,
Sandeep
Imtiyaz Ali 16Imtiyaz Ali 16
Mr. Danny Hallgren StL! thank you.
Saul ParkinsonSaul Parkinson
Thanks Danny Hallgren StL, very helpful. 
Sindhura ManthapuriSindhura Manthapuri
Create a new profile, name it "Basic Account User" and user licensee - Salesforce. In Standard Object Permissions section -> just check Read and edit checkboxes and save the profile.

Go to Accounts - > Fields -(Pick rating field) - > click button "Set field level security" and uncheck everything in visible and read only check boxes  expect for basic account user - > visible and readonly should be checked only for basic account user basically.

Permission Set -> object setting -> Account-> field permission section -> check read & edit then save.

​This worked for me.
Maricor Roth 8Maricor Roth 8
Thank you.
rafiya hassanrafiya hassan
thanks..