+ Start a Discussion
AmedeoAmedeo 

Error during importing leads

Hello,

Im experiencing this problem when try to import leads through the Launch Wizard:

Your import failed: Import for object Lead did not succeed. Error received - sObject type 'CampaignMember' is not supported. If you are attempting to use a custom object, be sure to append the '__c' after the entity name. Please reference your WSDL or the describe call for the appropriate names.

Anyone can help me to figure it out?
Best Answer chosen by Amedeo
AmedeoAmedeo
Hi,

Support already solved my issue:
There is a known problem with the new Import Wizard. Solutions are :

• Use the legacy wizard by navigating to below url
https://eu5.salesforce.com/lead/leadImportWelcome.jsp

OR

• Setup -> Data Import Wizard
The top right has a link to all the legacy importers:

Legacy Data Import Tools : https://eu5.salesforce.com/ui/setup/imp/LegacyImportersWelcomePage

Here, you can choose any of the following:

Go to the old Import Tool for Accounts/Contacts
Go to the old Import Tool for Leads
Go to the old Import Tool for Custom Objects

All Answers

Always ThinkinAlways Thinkin
Does the User you are logging in with to do the import have the Marketing User checkbox checked on the User Details? This is necessary to grant the importing User access to the Campaigns and Campaign Member objects. 
AmedeoAmedeo
Hi,

Support already solved my issue:
There is a known problem with the new Import Wizard. Solutions are :

• Use the legacy wizard by navigating to below url
https://eu5.salesforce.com/lead/leadImportWelcome.jsp

OR

• Setup -> Data Import Wizard
The top right has a link to all the legacy importers:

Legacy Data Import Tools : https://eu5.salesforce.com/ui/setup/imp/LegacyImportersWelcomePage

Here, you can choose any of the following:

Go to the old Import Tool for Accounts/Contacts
Go to the old Import Tool for Leads
Go to the old Import Tool for Custom Objects
This was selected as the best answer
Always ThinkinAlways Thinkin
Thank you for sharing that helpful information, hopefully others who encounter it will benefit from your issue. Do mark that as the Best Answer if it fixed your problem so others will know it works.
James GriffeyJames Griffey
Thank you! Using the old import tool for Leads worked for me. I used the same file I was using in the new tool, and it went thru just fine. But the new tool was giving me an error, and had no specifics around the error.