+ Start a Discussion
Soumya BeheraSoumya Behera 

Don't see any meta data attribute saying Available for Customer portal.

Hi All,

In the development box , i have marked one of the custom object as "Avaible for the customer portal ". So now i wanted to deploy the same attribute/property to other org. I have tried to fetch all the attribute of that particular custom object , however i have not find anything with the customerportal .
Can somebody guide that whether we do have any attribute or we need to do manual post deployment steps.

Regards,
Soumya Behera
Best Answer chosen by James Loghry
pconpcon
I missunderstood your original question.  I'm sorry.  It looks like this is not something you can currently do via the Metadata API so you will have to do it manually.  I would recommend upvoting this IdeaExchange post [1] and hopefully it will be delivered.

[1] https://success.salesforce.com/ideaView?id=08730000000l7wqAAA

All Answers

pconpcon
How are you fetching this data?  If you are using the ANT deployment tool, what version of the ant-salesforce.jar are you using?  What API version do you have in your package.xml?
Soumya BeheraSoumya Behera
Hey Pcon, 
Thanks for the response . I was using the workbench to fetch the object using the package.xml version (35.0) . 
pconpcon
I missunderstood your original question.  I'm sorry.  It looks like this is not something you can currently do via the Metadata API so you will have to do it manually.  I would recommend upvoting this IdeaExchange post [1] and hopefully it will be delivered.

[1] https://success.salesforce.com/ideaView?id=08730000000l7wqAAA
This was selected as the best answer
Soumya BeheraSoumya Behera
Thanks Pcon. Really apprciate your response .
pconpcon
Sorry to be the bearer of bad news.  If you don't mind, please select the "best answer" so that this question can be removed from the unresolved queue.