+ Start a Discussion
dimpledimple 

Issue with the Appexchange data loader CLI

Hi,
 
I am using the CLI of Appexchange data loader and i am getting the below error. I am using java version 1.4.2_08. What is required to fix this issue. Also if i upgrade the jvm to 1.5 then i get a error message saying that the data loader needs version 1.4.
 
Please advise
 
C:\config>java -jar sforcedataloader.jar
2006-10-19 14:04:14,204 INFO  [main] controller.LoaderController initConfig (LoaderController.java:287) - The log has be
en initialized
2006-10-19 14:04:14,220 INFO  [main] LoaderEngineRunner main (LoaderEngineRunner.java:78) - Initializing engine
2006-10-19 14:04:14,220 INFO  [main] LoaderEngineRunner main (LoaderEngineRunner.java:85) - Loading parameters
2006-10-19 14:04:14,220 INFO  [main] LoaderEngineRunner main (LoaderEngineRunner.java:96) - Logging in to salesforce.com
 
2006-10-19 14:04:15,908 WARN  [main] httpclient.HttpMethodBase readResponseBody (HttpMethodBase.java:2091) - Response co
ntent length is not known
2006-10-19 14:04:16,440 ERROR [main] client.PartnerClient connect (PartnerClient.java:142) - ; nested exception is:
        javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: No trusted certificate found
2006-10-19 14:04:16,440 ERROR [main] LoaderEngineRunner main (LoaderEngineRunner.java:126) - ; nested exception is:
        javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: No trusted certificate found
 
Thanks, Dimple

Message Edited by dimple on 10-19-2006 06:19 AM

EnderEnder
If you type java -version at the prompt, what shows up? 

Not having a valid SSL cert in 99% of the time means that the version you think you are using is not the one you actually are.  Make sure its 1.4.2_05 or higher.

-Lexi