+ Start a Discussion
mjmiedemamjmiedema 

Hard time getting right field name

I am trying to get one custom text field filled with a text depending if the Comment field in the task is filled or is empty. The syntax should be a straight forward one (I think) : if (Comments <> "" , "Full" , "Empty").
 
The problem I am having is that I keep getting : Error: Field Comments does not exist. Check spelling.
 
But where ever I search I cant seem to find the right name of the field name of Comments.
 
Is there anyone who knows :
 
1. if the syntax I use is the right one
2. where can I find the proper field names I should use ?
 
Thanks !
RickyGRickyG
Go to the page for the field and look for the API Name.  If Comments is a custom field, the name should be Comments__c

Hope this helps.
mjmiedemamjmiedema

Thanks Rick,

But there are two issues. First place I am refering to the standard field Comments (field name Description) of Sales Force in activitys. My formula is if(description<>"","memo",nul). It still reacts with the error where it claimes that the field Description does not exist.

I also tried it with another field (this time a existing custom field) and used the api notification : memo_c. it still tells me the field name does not exist.

It must be that I am using the formula incorrectly ??

Thanks for helping out sofar !

Mike

RickyGRickyG
Mike -

I'm tracking down an answer for your question about the comments.  But I think you may have a spelling error for the memo_c field.  All custom fields in Force.com have a naming convention of field name, two underscores, and then the c character.  Could that be the problem?

If so, I feel your pain - or rather, I felt it acutely for several of my early months, and only as an occasional dull throb these days . . .
jyotijyoti
If you use Eclipse IDE, there is an option for salesforce.schema.  For me, this has been a failsafe way to get the correct API name for every field.
mjmiedemamjmiedema

Rick, thanks for the update. I was hopefull and yes I see now that there is a double __ instead of a single. Is there anyone out there who finds out this by him/herself ?? ;-) But no it keeps giving me the same error. None such field exists. i am wondering if the formula field only works with number fields ?

Thanks also jyoti, I havent got a clue yet what Eclipse IDE is but i will find out and see if this will generate the right name.