+ Start a Discussion
MKPartners.comMKPartners.com 

Read Timed Out trying to delete records

I'm trying to delete 100,000+ cases via the dataloader.  The process usually starts fine and will delete 200-1000 records successfully.  It then seems to stop and eventually timeout with the following error:
 
org.apache.commons.httpclient.HttpRecoverableException: java.net.SocketTimeoutException: Read Timed Out
 
I have tried the same procedure using the Excel Connector and get the same results.
 
I am able to query successfully, just not delete.
To make it weirder, when logged into the app, I've been getting some timeouts when trying to Mass Delete and even when trying to just delete a single case.
 
Things to consider:
This is a sandbox org
We have external id's for cases and contacts (though I turned them off and still get the same result)
I've been more successful at deleting cases that do not have a value in ContactId than those that do have a vlue.
 
Has anyone ever experienced anything like this?  Does anyone have any ideas as to what could be causing these timeouts?
 
Thanks in advance

Message Edited by MKPartners.com on 11-09-2006 10:33 AM

Message Edited by MKPartners.com on 11-09-2006 10:34 AM

benjasikbenjasik
I'd either decrease your batch size to say 100 in the data loader, increase your timeout in the data loader, and log a ticket so our perf team can look into it.  Shouldn't be timing out on deletes.
MKPartners.comMKPartners.com
I'm getting the read timed out errors again.
 
I tried lowering my batch size to 50 but that didn't help.  My Timeout is set to 540 seconds, do you think we really need it to be longer than that?
MKPartners.comMKPartners.com
This is not an API issue, it's an issue with the database.
I have confirmed the problem on both Sandbox and Production.
When I set my batch size to 1 in the DataLoader, it takes 55 seconds to delete a single case record.
It is taking the same amount of time when deleting a single record from within the app.
 
I have called support multiple times and even though they say the case has been escalated to tier 2, I have not received a call from Tier 2 support.
 
Can anyone at sfdc help me out and take ownership of this issue?  The project is for a big named customer.

Thanks,
Matt