+ Start a Discussion
GrantMGrantM 

emailauthor not populating To field

Hi,
 
We have been using the emailauthor custom link to send mails from within saleforce.
 
This custom link looks like this:
This worked fine before the 07 release.
But now it does now populate the To: field anymore.
 
Please Help!
 
TIA
 
 
benjasikbenjasik
Note that our form field names are not an api.  You'll have to look at this page and what the form name changed to, but note that this type of integration can break across releases.
GrantMGrantM

Thanks Benji, this makes good sense.

But now i'm trying to populate the To field in this email author link, but can only seem to populate it using a Users ID.

So if change my links parameter to be as follows:

?p2_lkid=[users id]

This is working fine.
But i only have the users name to work with. So how do i populate it in this case?
I'm expecting:

?p2=FirstName LastName or
?p2_lkid=FirstName LastName

Though none of these besides the ID seem to work.
What am i doing wrong? Or is this not possible?

Unforunately only the Users Name is available to me, and not their ID.

TIA again