+ Start a Discussion
cgoncorpcgoncorp 

Upsert error: duplicates value on record with id: xxxx

I have a strange problem.
I started using the upsert call on accounts in salesforce.com.
I created the external id and batch uploaded 200 accounts.
I even tested running a few more after that run to make sure that the "update" was happening and not creating any duplicates. All was fine.
 
I then wanted to do a full run, so I decided to clean out my data in salesforce.com (mass delete of accounts) and run my program again. Now I keep getting:
 
duplicates value on record with id: xxxx
 
when I try to run the upsert on the first 200 records that I was testing with.
 
At first I thought it was becuase they were still in the recycling bin, but even after emptying it, I still get this error. It is always the same ID that gets referenced for all upserts in my 200 account batch. When I try to go to that account ID (manual copy and paste to the url) it says the record has been deleted.
 
Any ideas?
 
Carlos
 
benjasikbenjasik
This is known issue.  Should be fixed towards the end of this week.  Please log a case, and we can let you know the exact timing around the fix.
cgoncorpcgoncorp
Thanks for getting back to me.

For right now, I worked around the problem by unchecking the unique attribute of the External ID.
That seemed to do the trick, but obviously this is not an optimal solution.

I hope this helps someone.

Also, I don't know how to log a case, so if someone wants to take this on I would appreciate it.
Otherwise, I am ok for now.

Carlos


Roger1Roger1
Benji,

As of today (3/23/07) this problem hasn't been fixed, as I'm also experiencing the same issue.

I still can't do upserts on deleted records when they're marked as unique.

Any updates on this?

Thanks,

Roger