+ Start a Discussion
SennahSennah 

Bug-report: Page layout editor, VisualForce element

Dear tier 3,

 

this post regards a bug in the page layout editor.

I just had a phone call with tier 1 telling me that they can not escalate this due to some kind of internal rule and the only thing I can do is to post it on the developer-force.

 

Although I don't care if this gets fixed I wanted to make it public to point out how senseless this whole bug-reporting thing is. A customer (me) takes the time to report this error in your Software and you telling him (me) that you won't file the bug because I don't have developer support?

 

Here's how to reproduce the bug and get the exception:

Open the page layout editor with a VisualForce or S-Control in it.

Edit the VF element, set the height to null (leave the field empty).

Then try to save the layout. An exception will be thrown.

 

This is not only happening in my live org. You can reproduce it in every org.

 case:

#03001352

 

So far,

Hannes

Jordan Pogon (Salesforce)Jordan Pogon (Salesforce)

Hannes,

 

I apologize for the initial response that you received, as this issue should have been diligently investigated and escalated to the appropriate team in customer.  I have taken ownership of this case, and will be in touch with you directly to get all the necessary details of this issue to ensure that the appropriate corrective measures are taken going forward.

 

I thank you in advance for your continued patience.

 

 

Jordan Pogon (Salesforce)Jordan Pogon (Salesforce)

Hannes,

 

We managed to reproduce this issue ourselves internally and would like to thank you for the information provided.  As you described, this error seems to occur when an Scontrol or VF page's height/length is empty (i.e. not zero).  A bug has been logged to have this issue fixed in a future release (no ETA at this time).  However, that said, you can easily workaround this issue by setting the height/length of your Scontrol/VF page to 0 instead of "empty".