+ Start a Discussion
Keith654Keith654 

sf:deploy failure "Error: objects/User.object(User):Entity cannot be untracked."

My deploy from Ant failed this morning to a new "Developer Edition" org with this error; I have a few custom fields added to the User object. This deployment has been working fine and is run very frequently because we use continuous integration.

 

Does anyone have insight into this error?

 

Thanks,

Keith

Best Answer chosen by Admin (Salesforce Developers) 
PaulDysonPaulDyson

Found that there is a new tag in the User object and it appears to be the absence of this that is causing the problem:


<enableFeeds>true</enableFeeds>

 

Add this and you should be able to deploy as normal.

All Answers

PaulDysonPaulDyson

Nothing to add other than that our daily build has just started failing with the same problem.

PaulDysonPaulDyson

Found that there is a new tag in the User object and it appears to be the absence of this that is causing the problem:


<enableFeeds>true</enableFeeds>

 

Add this and you should be able to deploy as normal.

This was selected as the best answer
Keith654Keith654

Thanks Paul that fixed it.

JonPJonP

What API version are you deploying with?  It should be in your package.xml file.

Keith654Keith654

My package.xml still contains <version>18.0</version> as it has for the last few months.

StephenBStephenB

Had the same thing with our deploy via ant, but on v19. I am deploying both standard and custom objects, and User is the only one where I have to manually add the tag - the enableFeeds tag isn't even in my other objects and they are deploying fine.

 

A bug perhaps?