+ Start a Discussion
asktheleadguyasktheleadguy 

Mail Merge Error Help EeXception CMMHOST GENMAILMERGEEXCEPTION

Mail Merge Error Help EeXception CMMHOST GENMAILMERGE EXCEPTION

Please ensure  word is installed on your machine
The object does not support attached text . 5917

I already have  word installed on my desktop
Best Answer chosen by Admin (Salesforce Developers) 
VTVT

Hi All,

 

A workaround that actually works consists in saving the file that you will be using as a template as a "Word 97-2003 Document" (compatibility mode) and uploading this file to Salesforce.  The templates will then work fine (at least for us) with no errors.  We then save the files as Office 2007documents.

 

It's a band-aid but it works.

 

Alex 

All Answers

ChuckDChuckD
I'm having a problem with this too; using Word 2007, have installed the Office Connect from salesforce and am working on several merge templates. the problem seems to be related to tables and/or boxes on the form that contain the merge fields.
would appreciate any suggestions! :)
wpatterswpatters
This is a problem with me too, if anyone knows a solution, i would be eternally grateful
JoyDJoyD

I found this in the Help & Training, I was having this problem before and I think this might've solved it.  That, or they gave me a new computer because we couldn't figure it out... :-\

 

Before upgrading to Salesforce.com Mail Merge with Windows Vista and Word 2007 compatibility, please perform the following steps:

Note: You must be logged into your PC as a Windows user with sufficient administrative privileges to change the settings described. If you are unable to make these changes, please consult your internal IT Administrators.


    1. Open the Microsoft Windows Control Panel. For Windows 2000 and XP users, click 'Add or Remove Programs.' Windows Vista users should click 'Programs and Features.'


    2. If present, remove the program 'Salesforce Mail Merge.'

   

    3. Open the Internet Explorer web browser.

   

    4. IE 6 users:

        o Click Tools | Internet Options to open Internet Options dialog.   

        o On the General tab, click 'Settings' button in 'Temporary Internet Files.'

        o Click 'View Objects.' The file directory 'C:\WINDOWS\Downloaded Program Files' will open.

        o Delete following items if present: 'CMMHost Object' and 'SFCom Control.'


    5. IE 7 users:

        o Click Tools | Manage Add-ons | Enable or Disable Add-ons.

        o In the 'Show' drop-down list, choose 'Downloaded ActiveX Controls (32 bit).'

        o If the following items are present, select one at a time and click 'Delete:' 'CMMHost Object' and 'SFCom Control.'

        o Click 'OK.'


    6. Close Internet Explorer.


***Note: As a workaround, close all Microsoft Office programs and then try to create the mail merge document.

barryschnellbarryschnell

I have encountering this same issue and have isolated it down to the document containing a Line shape.  If I remove the line the exception is no longer encountered.

 

Was anyone able to resolve the issue aside from removing the shapes?

VTVT

Hi All,

 

A workaround that actually works consists in saving the file that you will be using as a template as a "Word 97-2003 Document" (compatibility mode) and uploading this file to Salesforce.  The templates will then work fine (at least for us) with no errors.  We then save the files as Office 2007documents.

 

It's a band-aid but it works.

 

Alex 

This was selected as the best answer
rasfischerrasfischer

Hi VT,

 

Thanks for your help, worked like a charm.

 

You saved me al lot of time and many grudges.

 

Rasmus Fischer