+ Start a Discussion
rob_ocprob_ocp 

Salesforce Mobile with Blackberry Simulator B8707g

I am in the midst of testing the Salesforce Mobile with the Blackberry Simulator B8707g.
I am recieving the below error message.
"Unable to register your Simulator because you are attempting to create a Simulator device and the device address is in use by another user"

How to change the device address? Have anyone of used this simulator?
Any lead to this issue is much appreciated.

Best Answer chosen by Admin (Salesforce Developers) 
NSDavidNSDavid
You may have already given up on this, but I figured I'd share a possible solution.

Browse to folder where the files for the simulator are stored and edit the .bat file with the version number you are using (in my case 8830.bat). Within that file, change the /pin variable to something other than the default (you may have to try several different option before finding one that works). Just make sure to keep the =0x portion at the beginning.

This resolved the same issue for me.

All Answers

N-forceN-force
Hi,

I am also experinceing the same. Do you accessing simulator in proxy env of your corporate network.

I have tried out side of proxy env it is working fine but not in proxy env. pls update this forum if anyone using simulator in proxy enviroment. Thanks
rob_ocprob_ocp
I am using within the corporate network. How did you make it work outside the proxy? Any leads will be helpful.
barretmacqbarretmacq
First you need to make sure you have the MDS simulator services installed. Then follow these instructions here How To - Configure the Blackberry MDS simulator to work behind a proxy
 
Barret
NSDavidNSDavid
You may have already given up on this, but I figured I'd share a possible solution.

Browse to folder where the files for the simulator are stored and edit the .bat file with the version number you are using (in my case 8830.bat). Within that file, change the /pin variable to something other than the default (you may have to try several different option before finding one that works). Just make sure to keep the =0x portion at the beginning.

This resolved the same issue for me.
This was selected as the best answer
PRTKPRTK
I just uninstalled, restarted and reinstalled the client in my PC and it worked.
nussbapjnussbapj

From the RIM web site:

Details
To set up the BlackBerry MDS Simulator to function behind a proxy, the rimpublic.property file needs to be modified to include that proxy information.

Open the rimpublic.property file. The rimpublic.property file can be found in the following locations:
For BlackBerry MDS Simulators installed with BlackBerry JDE

\Program Files\Research In Motion\BlackBerry JDE #.#.#\MDS\config

For standalone BlackBerry MDS Simulators

\Program Files\Research In Motion\BlackBerry Email and MDS Services Simulators #.#.#\MDS\config

Under the [HTTP HANDLER] section, update the following:
application.handler.http.proxyEnabled = true

application.handler.http.proxyHost=hostname

application.handler.http.proxyPort=hostport

To include proxy authentication, update the following under the [HTTP HANDLER] section:
application.handler.http.proxyUser=username

application.handler.http.proxyPass=password

To include proxy auto configuration parameters, update the following values:
application.handler.http.proxyAutoConfig = true

application.handler.http.proxyAutoConfigURL=http://URL_to_Your_Config_File

application.handler.http.proxyAutoConfig.ScriptCacheTime=0

For the last listed parameter, change 0 to the amount of time you want the BlacKBerry MDS Simulator to cache your config file.

 

This worked for me.

rohit.marathe@tcs.comrohit.marathe@tcs.com

Hi,

Thanks for the solution. But tried this solution by changing PIN and testing the simulator, but for many combination it did not work. Can you give us detailed steps to configure SF blackberry simulator for proxy internet settings?

Thanks