+ Start a Discussion
lmjohnsonlmjohnson 

Web-to-Lead - HELP!!

We are trying to get a new web-to-lead form up and running and most of the code is working except for the following sections (we have all but three fields from the form coming into SFDC):

This section we are trying to set the lead record type to Education





In this next section of Code:
ED_Course Type Interest gets populated
ED_Date Request - does not get populated
ED_Staff Attending - does not get populated
And finally
ED_Comments does get populated



Interested In*

On-site Training
Hosting Course



Request Date*




Number of Staff Attending*





Comments



SFDC1adminSFDC1admin
Okay this did not post correctly the first time. The first section of code is


Code:
    <input type=hidden name="00N60000001efsA" id="00N60000001efsA" value="Education Host">
    <!--  Above line refers to Web Source Internal field  -->
    <input type=hidden name="recordType" id="recordType" value="012600000005ASO">
    <!--  Above line puts record type at Education  -->
 and the second set of code is this:

 
Code:
      <tr>
        <td><label for="ED_Course_Type_Interest__c">Interested In<font color="#FF0000">*</font></label></td>
  <td><select id="00N60000001eift" name="ED_Course_Type_Interest__c" title="Interested In"><option value="On-site Training">On-site Training</option>
  <option value="Hosting Course">Hosting Course</option>
  </select><td>

      </tr>
      <tr>
        <td><label for="ED_Date_Request__c">Request Date<font color="#FF0000">*</font></label></td>
  <td><span class="dateInput dateOnlyInput"><input  id="00N60000001eifs" name="ED_Date_Request__c" size="12" type="text" /></span><td>
      </tr>
      <tr>
        <td><label for="ED_Staff_Attending__c">Number of Staff Attending<font color="#FF0000">*</font></label></td>

  <td><input  id="00N60000001eifu" name="ED_Staff_Attending__c" size="20" type="text" /><td>
      </tr>
      <tr>
        <td><label for="ED_Comments__c">Comments</label></td>
  <td><textarea  id="00N60000001eifx" name="ED_Comments__c" type="text" wrap="soft"></textarea><td>
      </tr>
      <tr>

 

 

NYCMeghanNYCMeghan
This might be too basic a suggestion, but under lead settings under "The Behavior Used when Applying Assignment Rules to Manually Created Records" do you have "Keep Existing Record Type" selected?
lmjohnsonlmjohnson
Thank-you for the advice. I changed the settings and this did help, however, we still have one field that did not populate when I ran a test. So i am 3/4 of the way to getting the problem solved! Any other suggestions?