+ Start a Discussion
JonPJonP 

Using the Force.com IDE with Eclipse 3.4

We're looking into officially supporting Eclipse 3.4 in an upcoming release of the Force.com IDE.  If you've tried to install the IDE plugin into Eclipse 3.4, please help us by sharing your experiences here.

  • What issues, if any, did you experience while installing the IDE in Eclipse 3.4?
  • What features, if any, failed to work in Eclipse 3.4?  Were you able to resolve any of these issues yourself?
  • What features worked normally in Eclipse 3.4?  Have you used the IDE in Eclipse 3.3 or 3.2.2, for comparison?

Your feedback is invaluable to usin ensuring a high quality release.

 

Thanks,

Jon

salesforce.com Product Manager

werewolfwerewolf

I've been using it with Eclipse 3.4 for months.  By and large it appears to be working just fine.  I have noticed a couple of minor glitches which may or may not be related to 3.4:

 

Backtabbing (i.e. unindenting, aka shift-tabbing) in Visualforce pages is a little weird -- at some point some lines will unindent and others won't, so my code starts to look like granny's teeth.

 

The code complete intermittently does strange things.  For example, yesterday while writing a little Apex code, it started putting the completion text one dot too late, so if I typed System.currentPageReference(). the completion showed me the items for System. instead of currentPageReference().  It seems to be working fine today though.

 

Otherwise, so far I really haven't had any problems with it, and although I'm not in it all day every day, I use it fairly heavily.

SomeshSomesh

very valuable!

thanks much! for posting this.

we'll look into the completion lag. 

gaisergaiser

I used latest Force.com IDE with Eclipse 3.4 for some time and the only serious problem I noticed was that CTRL+S shortcut does not save file to server, so I had to use context menu: “Force.com->Save to Server” instead - which eventually forced me to roll back to Eclipse 3.3.2.

 

Another issue (minor from my point of view anyway) - code completion does not seem to be working consistently - at times it suddenly stops offering any options and then starts working again – all happens within one session on the same file. Sometimes it appears like it depends on the surrounding code because in different places of the file code completion behaves differently.

 

 

Other than that Force.com IDE 15  under Eclipse 3.4 seems to be working great and does not even have an issue with curly brackets which annoys me a lot in Eclipse 3.3.2 – every time when I put cursor at the end of the line with opening bracket “{”and press Enter it always creates closing bracket “}”. Previous version (14) of Force.com IDE did not have that problem.

 

lamayclamayc
Been using it with Eclipse 3.4 for many months and I haven't had any major problems. As for the control+S that one post mentions. For me, it does save it automatically to the server. That being said, I have another project instance where control+S doesn't save to server. I think it might be a setting. I think something must have changed that setting on my old project, but when I started a new project (using a new workspace), control+S works again (saves to server).
SomeshSomesh

Thanks for all the posts.

 

The Ctrl+S option will only work if your project is set to build automatically. This option should be available in the "Project" menu option in Eclipse's menu bar.

 

Thanks

 

gaisergaiser

The Ctrl+S option will only work if your project is set to build automatically. This option should be available in the "Project" menu option in Eclipse's menu bar.

 


Somesh, many thanks for the tip, it does seem to be working.