+ Start a Discussion
King KooKing Koo 

"Make Default checkbox when creating Record Type for custom objects is not enabled

Hi there

 

WOrking on a custom object and was trying to add a Record Type to the object.

 

On the screen there is this paragraph:  "Select the Enable for Profile checkbox to make the new record type available to a profile. Users assigned to this profile will be able to create records of this record type, or assign this record type to existing records. To make the new record type the default for a profile, select the Make Default checkbox."

 

However, the Make Default checkboxes aren't even enabled.  Is it because this is the very first Record Type I'm adding to my custom object?  If so then all profiles will have to have that as the default record type?  

 

Under what condition will I be able to see the "Make Default" checkboxes enabled?  I don't know if I'm missing something here.  

 

I'm using the System Adm profile.

 

Thanks a lot!

 

 

 

Best Answer chosen by Admin (Salesforce Developers) 
b-Forceb-Force

As this is first record type you are adding ob your custom object so , make default chaeck box is disabled [but by default selected , based upon does this record type is enabled for this profiel]

 

When you will create any other record type on same custom object, you will get this checkbox enabled ... Editable :)

 

Thanks ,

Bforce 

All Answers

b-Forceb-Force

As this is first record type you are adding ob your custom object so , make default chaeck box is disabled [but by default selected , based upon does this record type is enabled for this profiel]

 

When you will create any other record type on same custom object, you will get this checkbox enabled ... Editable :)

 

Thanks ,

Bforce 

This was selected as the best answer
King KooKing Koo

Hi there

 

Thanks for your quick reply!

 

I just tried creating another record type, but still none of the "Make Default" checkboxes are enabled....

 

I first created a Recod Type A .  I set that to Visible only to "Supervisor" and it's also checked in the "Make Default" checkbox for Supervisor.

 

Then I created a Record Type B, but the Make Default checkbox for the Supervisor is still not checked.

 

Did my above step sound not right to you?

 

Please advise.

Thanks

King KooKing Koo

Oh!  You know what, the checkbox does get enabled but it wasn't very clear to me at first - but I just tried one more time and this time realized the Make Default checkbox is enabled.  

 

Thank you!