+ Start a Discussion
ConstellaCaraConstellaCara 

Data Loader Install Issues

I've happily used the data loader over the past year, but in the past 2 months or so, it stopped working for me.  I've attempted to uninstall the loader and have re-downloaded it and tried to re-install it, but I continue to get an error message:
 
"The feature you are trying to use is on a network resource that is unavailable.  Click OK to try again, or enter an alternate path to a folder containing the installation package 'Sforce Data Loader.msi' in the box below.  Use source: [browse to folder]"
 
I assume this means that the last version hasn't truly been uninstalled, though I can't find any files that reference it.  My guess is that there's something in the registry that's tripping up my installation.  Has anyone else had this problem? 
 
If you have any suggestions for how to fix this, I'd be extremely greatful - unfortunately my IT support staff is as clueless about this as I am (frightening, I know).
 
Thanks in advance for your help,
-Cara
EnderEnder
First, when you say it stopped working for you 2 months ago, what do you mean by that?

Right now you seem like you are stuck in installer purgatory, which is a fate no salesforce user should have to partake in.  You can either try to fix the installer, or just put the right files in the right place.

----------To fix the installer (maybe) ------------------------------

To clear the installer, I'd first go to Settings -> Control Panel -> and uninstall the Sforce Data Loader, or the App Exchange Data Loader, or any other Data Loader variants. (a step you may have already taken).

I'd download the latest version of the AppExchange Data Loader just to make sure you have the most current version.

Now the msi's are cached in windows under C:\WINDOWS\Downloaded Installations,  so if you get the prompt again, you could look under there for the missing msi.  I am not experienced enough to know if there is something you need to delete, or change or whatever.  I would recommend not changing anything in there though.

--------------To get the Data Loader to just work --------------------------------------------------

If you are still stuck -- don't worry we just need to copy the files to the correct place.  The easiest thing to do is get another computer -- make sure the Data Loader is uninstalled or has never been installed -- and install it there. 

Take the files installed under the AppExchange Data Loader (commonly found under C:\Program Files\salesforce.com\AppExchange Data Loader)  and just copy that folder to your computer in the same place.  Then just click SforceDataLoader.exe and you should be good to go.  You can create a desktop link from there as well.

Hope this works.  If you run into any other issues please post again.





ConstellaCaraConstellaCara
Woohoo!   I gave up on the installer and just copied it from another PC - it works! 
 
Thank you very much!
-Cara