+ Start a Discussion
yoyoyoyo 

Force.com plugin for eclipse

Hi there

 

I'm getting this error when I try to install Force.com plugin 16.0 for Eclipse 3.4.2. My operating system is Windows Vista 64 bit.

 

I would appreciate any help.

 

Thanks

 

yoyo

 

Cannot complete the request.  See the details.
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.core/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/org.apache.xerces/[2.0.0,3.0.0)
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.html.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.validation/0.0.0
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j.xml/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/org.apache.xerces/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui 16.0.0.200906151227] requiredCapability: osgi.bundle/org.apache.xerces/0.0.0
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: osgi.bundle/org.apache.xerces/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui.editors.intro 16.0.0.200906151227] requiredCapability: osgi.bundle/org.apache.xerces/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.api 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.deployment 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.upgrade 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui.editors.intro 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.schemabrowser 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.xml.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.upgrade 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.xml.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.sse.core/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.upgrade 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.sse.core/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.html.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.upgrade 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.html.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j.lf5.util/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.sse.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.upgrade 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.sse.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j.spi/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui 16.0.0.200906151227] requiredCapability: osgi.bundle/org.apache.xerces/0.0.0
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: osgi.bundle/org.apache.xerces/0.0.0
Unsatisfied dependency: [com.salesforce.ide.api 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j.lf5.util/0.0.0
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j.xml/0.0.0
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j.spi/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.xml.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.ui/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.core/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.api/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.validation/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/org.apache.xerces/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.sse.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.sse.core/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.html.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.ui.editors 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.deployment 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.deployment 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.core/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.deployment 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.api/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.deployment 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.ui/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/org.apache.xerces/[2.0.0,3.0.0)
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/com.salesforce.ide.core/[16.0.0.200906151227,16.0.0.200906151227]
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/com.salesforce.ide.ui.editors.intro/[16.0.0.200906151227,16.0.0.200906151227]
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.html.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/com.salesforce.ide.deployment/[16.0.0.200906151227,16.0.0.200906151227]
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/com.salesforce.ide.core/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/com.salesforce.ide.schemabrowser/[16.0.0.200906151227,16.0.0.200906151227]
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/com.salesforce.ide.upgrade/[16.0.0.200906151227,16.0.0.200906151227]
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/com.salesforce.ide.api/[16.0.0.200906151227,16.0.0.200906151227]
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/com.salesforce.ide.ui/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/com.salesforce.ide.ui/[16.0.0.200906151227,16.0.0.200906151227]
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/com.salesforce.ide.api/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.core/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.feature.feature.group 16.0.0.200906151227] requiredCapability: org.eclipse.equinox.p2.iu/com.salesforce.ide.ui.editors/[16.0.0.200906151227,16.0.0.200906151227]
Unsatisfied dependency: [com.salesforce.ide.ui 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.api/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.ui 16.0.0.200906151227] requiredCapability: osgi.bundle/org.apache.xerces/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.core/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.ui 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.upgrade 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.api/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.upgrade 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.ui/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.upgrade 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.xml.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.upgrade 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.html.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.upgrade 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.sse.core/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.upgrade 16.0.0.200906151227] requiredCapability: osgi.bundle/org.eclipse.wst.sse.ui/[1.0.0,2.0.0)
Unsatisfied dependency: [com.salesforce.ide.upgrade 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.core/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.upgrade 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.schemabrowser 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.api/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.schemabrowser 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.schemabrowser 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.ui/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.schemabrowser 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.core/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.ui.editors.intro 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui.editors.intro 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.core/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui.editors.intro 16.0.0.200906151227] requiredCapability: osgi.bundle/org.apache.xerces/0.0.0
Unsatisfied dependency: [com.salesforce.ide.ui.editors.intro 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.ui/0.0.0
Unsatisfied dependency: [com.salesforce.ide.api 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: osgi.bundle/com.salesforce.ide.api/[16.0.0,17.0.0)
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j/0.0.0
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: osgi.bundle/org.apache.xerces/0.0.0
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j.xml/0.0.0
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j.lf5.util/0.0.0
Unsatisfied dependency: [com.salesforce.ide.core 16.0.0.200906151227] requiredCapability: java.package/org.apache.log4j.spi/0.0.0

 

 

mb101mb101
I'm getting the same error on Vista 32 bit
Abhinav GuptaAbhinav Gupta

It happens sometimes when one upgrades from Eclipse Europa to Ganymede. 

Try downloading fresh copy of ganymede from eclipse site.

 

Another good news for you is, force.com is coming with Eclipse galileo plugin in coming release.

mb101mb101

Thanks Abhinav.  This was a first time install and not an upgrade from Europa, but downloading a fresh copy did the trick...almost.  First I got the "no repository found.."  error when installing the plugin, but this was easily fixed by adding a trailing '/' to all repository URLs, as per other postings.  Now I'm up and running. 

 

-Mark

Abhinav GuptaAbhinav Gupta

Thats cool.

My suggestion now is to do no updates on ganymede, as my Force.com eclipse plugin crashed and stopped working, this happened when I did update on couple of eclipse features.