+ Start a Discussion
Paul Dyson.ax812Paul Dyson.ax812 

Unable to create new users in DE

I created a new DE this morning and the default user created for that org has its language value set to '2'. If I try and save changes to that user I get an 'invalid value' error although if I then set it to 'English' everything saves fine.

 

However, if I then try and create a new user I get the following error:

 

Unable to Access Page
Invalid parameter value "Language: bad value for restricted picklist field: 2" for parameter "LanguageLocaleKey". 

Error: The value of the parameter specified above contains a character that is not allowed or the value exceeds the maximum allowed length. Remove the character from the parameter value or reduce the value length and re-submit. If the error still persists, please report it to our Customer Support team and provide the URL of the page you were requesting as well as any other related information. 


 

This happens whether I use the 'New User' button or the 'Add Multiple Users' button. I will raise a case but anyone got any ideas of how to work around this problem?

Best Answer chosen by Admin (Salesforce Developers) 
Paul Dyson.ax812Paul Dyson.ax812

Managed to answer my own question. By going to the Company Information page and explicitly setting the default language to English I can prevent this happening. Although English displays as the default language when I view the Company Information page, when I edit it displays as 'none'.

All Answers

Paul Dyson.ax812Paul Dyson.ax812

Managed to answer my own question. By going to the Company Information page and explicitly setting the default language to English I can prevent this happening. Although English displays as the default language when I view the Company Information page, when I edit it displays as 'none'.

This was selected as the best answer
dkadordkador

Did you log a support case for this?  If not, please do so.