+ Start a Discussion
saisaisaisai 

New Junction Object unable to add new record.

I  have successfully created  a bugCase junc object by creating 2 relationships in the custom object and successfully see the related list called Bugs in Case and related list called Cases in Bug object.

Then i have successfully created a new case record from Cases tab.

Now when trying to create a new bug object by clicking on Bugs | New --> there r 2 lookups in this screen for Bug and have successfully selected from the Case lookup but when i click the lookup for Bug there r no records and only Go button is present but not the New button.

Then i have tried looking for Bug object in Customize but noticed it does not exist here also.

How to add a new Bug object.

Please help.

Thanks

Sai

sandeep@Salesforcesandeep@Salesforce

See I think you made some wrong thing in namanclature of these objects. 

As per your explainination you have created Case record. now bfore going to create junctin record you need to creae bug record. I think by mistake you are creating junction record at this time before bug( thats why bug record was not foung in lookup). You named junction object's tab to Bugs I think that is a cause.

 

so please check again namings and also keep in mind that to relationship names only come in junction record creation.

SanjaySSanjayS

You need to check security setting for Bug object ( to check if you have access to the object).

 

saisaisaisai

Thanks for your reponses the issue i continue to have is i cannot find the New button to create a bug record.

In other words i go to Create | Objects | Bug

Here i see only:

Edit  & Delete & Truncate.

 

I have also verified in Page Layouts and selected Buttons but the New button does not appear here.

Please let me know if you need more info.

Your help is really appreciated.

Thanks

Sai

SanjaySSanjayS

Go to Create -> Bug object  scroll to 'Search layout'.

Select Edit on ' Bugs List View'  and select 'New' under 'Standard Buttons.

 

SanjaySSanjayS

Also to add that this,  you need to select master-detail relationship. If you add as a lookup relationship the objects are read only.

That may be the reason you see a display only list.