+ Start a Discussion
tejateja 

campaign activation

I just wanted to know. As an admin how can i give access or permissions to my marketing user to activate and deactivate the campaign.

 

I already tried enabling them as marketing user and gave all permissions to read, create, edit, delete, view all and modify all permissions on campaign still after creating a campaign they can't check it as active while creating a campaign. 

 

Any help will be appreciated.

Best Answer chosen by Admin (Salesforce Developers) 
pgonzaleznetworkpgonzaleznetwork

Did you make sure the field is editable on both the page layout and field level security?

 

Remember that the field can be set to read-only on the page layout and also the field level security. 

All Answers

pgonzaleznetworkpgonzaleznetwork

Hi Teja,

 

Is the field not editable only while creating the campaign? as per your comment "they can't check it as active while creating a campaign." 

 

Does that mean they can check it after the campaign is created? In any case, most likely the field is set to read only on either the page layout level or field level security.

 

Try checking the field permissions for the user's profile and make the field visible/editable to this profile.

 

Please mark this post as "Solution" if it does fix your issue. Otherwise let's us know and we'll be glad to help :)

tejateja

no they can't activate even after creating the campaign and even in field permissions visible is checked already but still we they can't active any campaign its weird though any other things that i need to check or suggestions will be higly appreciable

pgonzaleznetworkpgonzaleznetwork

Did you make sure the field is editable on both the page layout and field level security?

 

Remember that the field can be set to read-only on the page layout and also the field level security. 

This was selected as the best answer
pgonzaleznetworkpgonzaleznetwork

Go to Your Name, Setup, Customize, Campaign, Fields and then click on Active.

 

Click on View Field Accessibility

 

The field should be set to Editable

 

If it says read only, click on it and change uncheck the read only checkbox.

 

 Go to Your Name, Setup, Customize, Campaign, Page Layouts and click edit next to all the page layouts that you have (if you have more than one).

 

Field the Active field, hover your mouse over it and click the wrench icon, make sure the field is not set to read-only