+ Start a Discussion
noreasternoreaster 

Outbound Message Error - 'Version Mismatch'

I have migrated my changes to another sandbox and when sending an outbound message the delivery failure reason is 'version mismatch'.  It worked fine in the other sandbox.  Has anyone seen this before?  Any ideas?  Thanks

danav@qualcomm.comdanav@qualcomm.com

I am getting the same problem in my sandbox environment. Can someone please comment on what the issue might be, I can't find any documentation on how to troubleshoot outbound message errors anywhere.

rmacherlrmacherl

I have got the same error and when I've deleted the '<xml version>' tag from the response and maintained only the '<soap:env>' part, it worked

Yugandhar Reddy 7Yugandhar Reddy 7
try this below format definitly its works
<?xml version="1.0" encoding="UTF-8"?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
 <soapenv:Body>
  <notificationsResponse xmlns="http://soap.sforce.com/2005/09/outbound">
   <Ack>true</Ack>
  </notificationsResponse>
 </soapenv:Body>
</soapenv:Envelope>