+ Start a Discussion
RobotiRoboti 

Reports not selecting the records on a custom object

Hi,

 

We have a custom object "Sales" on Opportunity. When we create a new report on Opportunity, we get the records. But when we create a new report on Opportunity and Sales with same criteria, we do not get any record.

 

Where are we getting it wrong?

 

Please help!

 

Thanks!

Best Answer chosen by Admin (Salesforce Developers) 
RobotiRoboti

Hi Sonam,

 

Thanks for your reply. We are now able to get the records. We wanted to create reports on Opportunity and Sales both.

 

We were selecting the Report Type as Opportunities and Sales. But when we checked further, we found Opportunities with Sales also. We then selected Opportunities with Sales as the Report Type, and we get the records now.

 

Thanks!

All Answers

Sonam_SFDCSonam_SFDC

Hi Roboti,

 

I understand that you have created a relationship between Opportunity and Sales(custom object) Object.

ON which object are you creating the report ? on Sales?

 

What are the filters you are using to get records?

RobotiRoboti

Hi Sonam,

 

Thanks for your reply. We are now able to get the records. We wanted to create reports on Opportunity and Sales both.

 

We were selecting the Report Type as Opportunities and Sales. But when we checked further, we found Opportunities with Sales also. We then selected Opportunities with Sales as the Report Type, and we get the records now.

 

Thanks!

This was selected as the best answer
RobotiRoboti
We are creating on Opportunity.
RobotiRoboti
We are not filtering the records now. So all the records should be available in the report.