+ Start a Discussion
tmatthiesentmatthiesen 

PRODUCT LAUNCH: The Winter '12 Force.com IDE was released yesterday

Best Answer chosen by Admin (Salesforce Developers) 
Thomas DvornikThomas Dvornik

A patch has been released to solve the timeout issue. Please update to 23.0.1.

All Answers

NzgonNzgon

Does enybody have problem to test APEX class (Controllers).

 

Result for test return just triggers coverage not coverage for class.

 

Nash

 

Thomas DvornikThomas Dvornik

Hey Nash,

 

I am able to test controllers with no problems. The results return both the trigger and class results. Can you provide any more detail?

NzgonNzgon

Today I am able to do it.

Yesterday result was coming just for triggers and test class.

 

Regards,

Nash

pfl_2000pfl_2000

Hi, I am behind a proxy server and am having trouble connecting with the Winter '12 version of the plugin.

Previous version worked fine as long as I setup the proxy.

 

New version will timeout when downloading code. Allows me to login (and validate credentials) but when it comes time to download, it sits for a while before timing out.

 

Does this new version use sockets vs http, or has something else fundamental changed?

 

 

Thomas DvornikThomas Dvornik

A patch has been released to solve the timeout issue. Please update to 23.0.1.

This was selected as the best answer
PaddyButlerPaddyButler

Still not connecting via a proxy for me. SF support have told me its a known issue. Cant even create a new tigger in eclipse because it needs to connect to do this

mambafiebermambafieber

After upgrading to 23.0.1, I can no longer choose any metadata component below 'object - standard' and 'object - custom' (see screenshot). I've checked with an older version installed on the same machine, and the ''Expand' images (plus signs in front of the object name) are there...

 

expand_objects_missing

Thomas DvornikThomas Dvornik

That is a reported issue and we are looking into it. I'll keep you posted.

pbattissonpbattisson

I can't seem to get email templates from DE orgs with the new IDE, is this a known issue or not?

Thomas DvornikThomas Dvornik

Yes, that is the same issue as the one posted above. 

Thomas DvornikThomas Dvornik

As a temporary workaround, you could edit the package manifest directly. For example, something like the following would just get 2 fields and 1 list view for Account.

 

<types>
    <members>Account.Name</members>
    <members>Account.<SomeCustomField>__c</members>
    <name>CustomField</name>
</types>

<types>
    <members>Account.<SomeListView></members>
    <name>ListView</name>
</types>

 You can do the same for emails, documents, etc, by just specifing each member. For example, the following would get an email template.

 

<type>
    <members>unfiled$public/<SomeEmailTemplate></members>
    <name>EmailTemplate</name>
</types>

 Please note that you need the folder name before the email (or document, etc). The default is unfiled$public.

mambafiebermambafieber

I have installed IDE version 24 from the software and workspace center, but still only complete objects are available. The workaround is ok, but I am wondering if a fix for the UI will be available soon.

Thomas DvornikThomas Dvornik

These issues should have been fixed in version 24. I just checked and I'm able to see objects expand. Did you try to refresh the metadata components when in the explorer? 

mambafiebermambafieber

Jackpot - I don't know why it didn't come to my mind after installing the update. Thank you very much!