+ Start a Discussion
jeff00seattlejeff00seattle 

Eclipse Force.com IDE Save Errors -- Installation Update?

Hi

 

The following seems to be a common problem with Force.com IDE, pertaining to Save Errors:

 

Save error: Unable to perform save on all files: com.salesforce.ide.api.metadata.types.Metadata$Jax​bAccessorF_fullName cannot be cast to com.sun.xml.internal.bind.v2.runtime.reflect.Acces​sor    **** line 1    Force.com save problem

 

There was a similar discussion about this issue 09/2011:

http://forums.sforce.com/t5/General-Development/Eclipse-Force-com-IDE-Save-Errors/td-p/332947

 

A community member had a solution and I am wondering if it is still up-to-date:

 

"Okay I got to the bottom of it. Solution:

- Use JRE v6 update 27 - 64bit (downgraded from JRE 7)

- Use JDK v6 update 27 - 64 bit (downgraded from JDK 7)

- Re-installed Eclipse SDK 3.6.2

 

 In short, downgrading solved the problem.'

 

I am install in Windows 7 64-bit

 

Thanks

 

Jeff in Seattle

Varun YagainVarun Yagain

Downgrading was unfortunately, the only thing that worked for me when I had the same issue 2 months (April-2012) ago.

 

Varun.

jeff00seattlejeff00seattle

Hi

 

I download the latest "Eclipse IDE for Java Developers" and with the recommended Java SDK and JDE update 6u27, and it worked perfectly.

 

However, I had to uninstall the latest Java SDK and JDE update 7u5

 

Thanks for the reply

 

Jeff in Seattle