+ Start a Discussion
treyeilandtreyeiland 

APEX Data Loader - "Failed to Create Batch" - "unable to find end tag"

I'm new to the Data Loader, so I'm testing the batch / command line capabilities.  In doing so, I got the batch api enabled and working within my sandbox, but my test insert job failed after 15,000 records.  I checked the space and that's not the issue.
 
The only thing I can see is the "unable to find end tag" error and I can't find any documentation on what this means.  Any help would be great.  Thanks!
 

 
 
2010-03-25 10:45:52,973 INFO  [deleteAccounts] action.ActionFactory getActionInstance (ActionFactory.java:64) - Instantiating operation: delete
2010-03-25 10:45:53,254 INFO  [deleteAccounts] controller.Controller executeAction (Controller.java:114) - executing operation: delete
2010-03-25 10:45:53,254 INFO  [deleteAccounts] action.AbstractLoadAction execute (AbstractLoadAction.java:130) - Loading Using Bulk API: delete
2010-03-25 10:45:53,426 INFO  [deleteAccounts] visitor.BulkLoadVisitor createJobInfo (BulkLoadVisitor.java:207) - Created Bulk API Job: 750Q00000008TqMIAU
2010-03-25 10:45:53,738 INFO  [deleteAccounts] progress.NihilistProgressAdapter setSubTask (NihilistProgressAdapter.java:68) - Aborting job
2010-03-25 10:45:54,082 FATAL [deleteAccounts] action.AbstractLoadAction execute (AbstractLoadAction.java:172) - Exception occured during loading
com.salesforce.dataloader.exception.LoadException: Failed to create batch
at com.salesforce.dataloader.action.visitor.DAOLoadVisitor.handleException(DAOLoadVisitor.java:165)
at com.salesforce.dataloader.action.visitor.DAOLoadVisitor.handleException(DAOLoadVisitor.java:169)
at com.salesforce.dataloader.action.visitor.BulkLoadVisitor.handleException(BulkLoadVisitor.java:107)
at com.salesforce.dataloader.action.visitor.BulkLoadVisitor.loadBatch(BulkLoadVisitor.java:91)
at com.salesforce.dataloader.action.visitor.DAOLoadVisitor.visit(DAOLoadVisitor.java:125)
at com.salesforce.dataloader.action.AbstractLoadAction.visitRowList(AbstractLoadAction.java:202)
at com.salesforce.dataloader.action.AbstractLoadAction.execute(AbstractLoadAction.java:148)
at com.salesforce.dataloader.controller.Controller.executeAction(Controller.java:115)
at com.salesforce.dataloader.process.ProcessRunner.run(ProcessRunner.java:130)
at com.salesforce.dataloader.process.ProcessRunner.main(ProcessRunner.java:222)
Caused by: [AsyncApiException  exceptionCode='ClientInputError'
 exceptionMessage='Failed to create batch'
]

at com.sforce.async.RestConnection.createBatchFromStream(RestConnection.java:148)
at com.salesforce.dataloader.action.visitor.BulkLoadVisitor.createBatch(BulkLoadVisitor.java:217)
at com.salesforce.dataloader.action.visitor.BulkLoadVisitor.doOneBatch(BulkLoadVisitor.java:133)
at com.salesforce.dataloader.action.visitor.BulkLoadVisitor.createBatches(BulkLoadVisitor.java:113)
at com.salesforce.dataloader.action.visitor.BulkLoadVisitor.loadBatch(BulkLoadVisitor.java:87)
... 6 more
Caused by: com.sforce.ws.ConnectionException: unable to find end tag at:  START_TAG seen ..."http://www.force.com/2009/06/asyncapi/dataload">\n <exceptionCode>... @3:17
at com.sforce.ws.bind.TypeMapper.consumeEndTag(TypeMapper.java:398)
at com.sforce.async.BatchInfo.load(BatchInfo.java:200)
at com.sforce.async.BatchRequest.loadBatchInfo(BatchRequest.java:75)
at com.sforce.async.RestConnection.createBatchFromStream(RestConnection.java:142)
... 10 more
2010-03-25 10:45:54,145 ERROR [deleteAccounts] progress.NihilistProgressAdapter doneError (NihilistProgressAdapter.java:51) - Failed to create batch 
Best Answer chosen by Admin (Salesforce Developers) 
d3developerd3developer

In my case the uiltimate problem was an outdated version of the Enterprise WSDL.

All Answers

d3developerd3developer

I'm having the same problem. Appears to be thrown by the TypeMapper in the com.sforce.ws.bind package:

 



    public void consumeEndTag(XmlInputStream in) throws IOException, ConnectionException {
        if (XmlInputStream.END_TAG != in.nextTag()) {
            throw new ConnectionException("unable to find end tag at: " + in);
        }
    }

 Here's the error message from my Google App Engine log:

 

Connection Error:unable to find end tag at:  START_TAG seen ...r &amp; Google Wave. So many possibilities</sf:Name><sf:Source__c>... @1:849:class com.sforce.ws.ConnectionException

 

As for why the XML coming back cannot be parsed correctly, I'm not sure.

 

 

d3developerd3developer

In my case the uiltimate problem was an outdated version of the Enterprise WSDL.

This was selected as the best answer
Seb OrtizSeb Ortiz

Sorry, I'm not following. No WSDL file is used when you run the Data Loader. I'm getting the same error message "Filed to crated batch" when performing a mass delete with Bulk API . Any ideas?

 

Please advise

Thanks

falcon_humanfalcon_human

1000 batch can only be done within one day