+ Start a Discussion
Andrew Mc.Andrew Mc. 

Force.com IDE wont connect to Salesforce to Start a new Project

Hi,

 

Anyone come across this issue?

I have installed versions 3.5 and 3.6 of Eclipse, and have successfully added the Force.com IDE plugin on both, not having to set any proxy settings as I am not sitting behind one. However when I try to start a new project, and entering my developer login details, I get the Unable to fetch organization details with a Connection timed out: connect error. I have tried this on another machine and all works ok, I am hoping this is a JRE issue, however I have jre 1.6_31 installed. Anyone any ideas or come across this issue before? I havent amended any environment variables should i be?

 

Any help advice is much appreciated.

 

Andrew

AdrianCCAdrianCC

Hello,

 

Try to delete/reinstall all the stuff. Again. :(

http://wiki.developerforce.com/page/Force.com_IDE_Installation_for_Eclipse_3.6

Be sure to use 3.6.1 as the guide says. You can try to use the JDK instead of the JRE(it should contain the running enviroment also). Stick to 1.6, 1.7 crashes the IDE(at least on my machine).

 

You mentioned having installed the ide on another machine(and it worked). Is it on the same network? Same OS? 

 

Good luck,

Adrian

Andrew Mc.Andrew Mc.

Hi Adrian,

 

Thanks for the advice, I dont think I've ever found it a smooth process to get Eclipse and the Force.com IDE to all work smoothly first time with a simple install.

I will give it a go at installing the JDK, its Eclipse version 3.6.1 that I have been using as per the guide. Will I need to set any environment variables when doing this?

 

The other machine was on the same OS but different network that worked. Im assuming there are no network issues as I didnt have any problem installing the Force.com plugin for eclipse, would i be wrong in my assumption?

 

thanks,

 

Andrew

AdrianCCAdrianCC

I didn't had to mess w/ the enviroment vars on both the Win7 at home and the OS X at work. I believe a java error would of been thrown it that was the case.

 

Try to connect to your instance using another product, like the Data Loader, to check htat the problem is not one network related.

 

Ty,

Adi

Janet GuoJanet Guo

Having multiple version of Eclipse and/or Java installed can cause problems. Have you made sure to specify your JVM as 1.6_31?

 

This article might prove helpful.

Amit LuniyaAmit Luniya

I think this post is little old one but still want to share the solution that worked for me.

 

You may face this issue because of firewall settings and configuring proxy server settings will do the trick.

Please go through my below blog for detailed steps of the solution.

 

http://aluniya.blogspot.com/2013/12/unable-to-fetch-organization-details-for.html

 

Please Accept my answer as solution (if it was helpful) to make it available to others for similar problem & Don't forget to give me KUDOS by Clicking on STAR icon